Installing stops at agent (Fix Edit: need to expand file system)

I’ve done a fresh install of Raspian followed by the wget and running the shell script.

When I go to the myDevices dashboard it hangs on installing the dashboard

Here is a screen shot

I generated a new device and went through the procedure again with the same results.

Any help is appreciated.

Are you using Jessie Lite?


I don’t think so. How can I tell?

I used the NOOBS installer and chose the first one. I have a 64G card so I didn’t mean to install the lite version.

It boots into a GUI and has a lot of preinstalled programs.

I’ve been reading through things and wonder if my firewall is blocking the connections. It sounds like both the device and the web client connect through your host. Depending on the outbound port number I may have it blocked.

Hmmm. Are you taken into the dashboard when click this link?

Are you on a wifi dongle?

The Pi and my computer are both connected to ethernet, on the same IP range and the same switch.

When I click on the link it takes me to the first screen where I click next and then it goes to the screen in my pic where it stops at installing agent.

Hi Joel,

I’ll PM you to continue trouble shooting.


Hi Joel,

Did you expand your SD card prior to installation?

I followed the NOOBS instructions running the SD formatter using the format size adjustment to ON. Since the card is 64gig I ran something to make it FAT32 and then copied NOOBS onto it. The install seems to work OK. I’ve been playing with it and everything is running good.

Hi again Joel,

Seems like the install is working now for you, which is great. Just curious, what have you been playing with? Did you have a certain project in mind with Cayenne?


I am having the same issue. I’m running a headless Jessie (Hypriot Linux) on a RaspPi2. I have a 32GB partition with about 24GB free. Installation finished and RaspPi rebooted. But it just hangs on the Agent with a spinner. Any ideas?

It still is not working. Just hangs installing the agent.

still not working. Started again with “sudo sh -v”. It rebuilt, installed, rebooted, but the screen still stays on Agent.

hello there I have the same issue overhear it’s just hangs installing the agent.

Are you using Jessie Lite?


nope I’m using the full one

Did you expand the filesystem?


Same problem here. I have expand filesystem, my raspberry Pi is connected on wired internet and I am using full version of Jessie. I figured out that the cron report error messages in any seconds via root mail system. Is there way to remove myDevices perfectly? I mean, without formatting my raspberry Pi.


Did you SSH and copy paste the install text? Or did you manually type into the Pi terminal?

I ask because it’s very easy to mistype the install text, especially with the number ‘1’ and the letters ‘i’ ‘l’ ‘s’ ‘5’ ‘0’ ‘o’ (we are working on a solution to make this text easier to type too)

I installed with SSH connection and I copied the text and pasted it. Also, my iPhone App couldn’t find my Pi indeed connected with same network with my Pi.

Would there be a reason why would be blocked? We’ve seen instances where the install Cayenne cannot work when on a company network, but then when the Pi was brought to a home network it was working just fine.