iPhone\iPad iOS Dashboards Differ From Website

  • Device & model you are using - Raspberry Pi 3, Raspbian 9; iPhone, iPad (latest iOS) & Safari Web Browser on iMac,
  • What dashboard are you using? Web & iOS both

The iOS version acts like a different application than the web. Although it shows some default widgets, the dashboard doesn’t match the web browser version. On iOS I cannot add any objects to the Dashboard. There is no drag and drop feature. If I add a widget on the iPhone, it shows successful but never adds to the dashboard on the phone. I tried this several times and when I logged onto the site with my Mac and browser, there were several of the widgets on the dashboard. Still none on the iPhone or iPad. So it was adding the website version but not my devices.

An observation; the web version tends to go offline often. Possibly due to the app open on my phone simultaneously…?

I am new to this so I apologize if I am missing something.

To clarify, this renders the site and software unusable. Please help!



Hi guys!

I’m having the same issues: Cayenne Dashboard discrepancies between Web and iOS.
@jkmusic, I really don’t want to hijack your thread, just contribute my 2 cents by sharing whats is happening in my case.

I believe the problem must me the iOS app. The same web dashboard works fine, and shows the exact same results across different computers I’ve tried (at home, at work, my wife’s etc.). Everything is smooth and consistent on the web browser.

OTOH, on the iOS app, sometimes (quite often) widgets don’t update, button states are not correct, and even the widget “types” are not the ones I chose on the web browser (charts appear as Values, etc.)

I tried reinstalling the app, wiping the dashboard, generating a new client_id, but problems remain. For example, take a look…

Web (correct)
Boiler is Off, thermostat is Off.

iOS (Wrong!)
Boiler shows as On, and so does the thermostat.

Hope this helps!