iOS app unstable

Cayenne seems a really good idea, but initial attempts to use it are deeply disappointing.

iOS app found my 2 x Raspberry Pi OK, but no amount of trying will make the widgets work as I believe they should

  • “hiding” a widget followed by “save” makes no difference. It vanishes, but reappears next time you open the app.

  • Graphing data (temperature) works, but only seems to accumulate data whilst the app is open. After several hours there seems to be nothing there. Accessing web version of dashboard via Firefox from PC can’t find anything either.

  • Web site useless from Safari, it just keeps pointing me at the App Store even though I have the app.

I was hoping to save myself a lot of coding!

do you mean deleting the widget?

you need to change the option to last hour or last day to view the previous data. Have you tried on Google Chrome?

this is because the cayenne dashboard size is large and cannot fit on the mobile screen. Thus it prompts you to download the app.

  1. List item

Background - this is talking about the IOS app running on an iPad on iOS 12.1.0. I have two Raspberry Pi’s registered to Cayenne and, for the moment, the only widgets are the ones that track internal parameters of the Pi (CPU, RAM, Storage, Cpu temp, NW speed) and provide reset and reboot. My plan is to have the Pi’s use DS18B20 temperature sensors to monitor environment, once I have understood how all this works!

  • Hiding widget - no, - I mean “hiding”. Click on cog for a widget in iOS app, set the “hide widget” switch to “on”, click on “save”, “success” message appears. Click “back” arrow and bingo, widget is hidden. Swappiing between devices and it remains “hidden”. BUT, leave the app (ie close down from memory) and come back to is and the widget has re-appeared. What is the point in having “hide” if it is not remembered???

  • Graphing temperature - no, I try to avoid Google as much as possible and Chrome will not run properly on Windows 10 anyhow! I have tried from Windows Edge, same thing. It is not at all clear how to set up graphing to collect and access historical data! For the moment I am trying to do this just for CPU temp as a proxy for my long term goal. Can you point me to clear instructions on how to do this?
    I have tried (a) in the app to select m/h/d etc and it just says “no data for this period” even when live collection has been running, for example, for much longer than a minute. It is not clear what those letters mean - do they mean “set the collection interval” or do they mean “display graph of data for this period”? Where is this explained? (b) same thing on the web dashboard as well as trying to use the date range (option not visible in the app - why???) but it makes no difference.
    Am I wrong in assuming that the moment a widget is activated historical data is collected? If not, how and where is that turned on?

  • Web site on an iOS device - really? Is that a wise design point given the size of an iPad screen? In any event on my iPad the web site fails to display properly 3 links that I have discovered on top right of the screen. If there is insistence on not working on iOS how about an explanatory message rather than just a frustrating screen?

PS - I can provide screen recording captures of all this happening if you want and it would help.

PPS - from the web interface by “roll over” it becomes clear what the m/h/d etc over the graphing mean - but there is nothing (that I can locate!) in the app that explains this so one is left guessing!.

thanks, for reporting this issue. team is working on it. will let you know once it is fixed.

All default widget like CPU, RAM etc do not have data history other than showing live data. this is the intended behavior.
All other sensors which you will be adding to your pi will store data history and show in graph.

thanks for reporting the issue with the top link on the top right, we will have it fixed soon.
as for iPad, is it iPad mini or pro? i guess it wont work on mini and i have not tested on Ipad pro also. If it does not work on Ipad pro, then the dashboard size does not fit it the ipad scree.
A workaround which works on android phone using google chrome is to enable the Desktop site in setting.

Shramik - thanks for swift response!

Understand Cayenne working as intended for internal Pi parameters.

Web site - I’m using iPad Air2 now on iOS 12.1.1 as of 30mins ago. I’ve now tried “request desktop site” as one can do that in iOS too. It makes no difference, just takes me back to the screen linking me to the app. Something about how your server is handling the request when it identifies the requesting device type?

I won’t have the external sensor running for a couple of days (waiting for parts!), so let’s see how that goes.

i guess then the Desktop site workaround does not work on the IOS devices.
when you have your hardware arrived, connect it and let us know if face any issue.

Out of curiosity installed Chrome for iOS and tried it with that. Still does not give desktop site, but, interestingly, Chrome does then seem to believe it has the desktop one because its option changes to “Request Mobile site”!

These things are never simple! :cold_face::worried: