Issue with actuators and ds18b20 sensors

Thank you for taking the time to submit your bug/issue! Please use the points below as a guide when submitting.

  • Device & model you are using (Ex: Pi 2 Model B or Arduino Uno with W5100 ethernet shield)
    RPI3 and PLCduino (mega)
  • What dashboard are you using? (Web, iOS, Android)
  • Please describe the bug / issue as detailed as possible. Attaching the code and any relevant screenshots would be very helpful!
  1. First the temp sensors quit working. They would only show 32 or - so I decided to remove them after shutting down the Rpi. I made a much more reliable setup thinking maybe there was a problem with my crazy breadboard wiring. wired up one wire then power then powered up Rpi.
    Then as happened last year they began populating by the dozens. Twice I removed sensor by sensor and tried again. Today they populated properly and are behaving except some occasionally show disconnected.

  2. The actuators for my Rpi and PLCduino have quit responding. A few days ago I noticed that clicking on an actuator button would actuate the relay but the button would revert back to off(relay still energized) and vice a versa. Now not only do they behave this way but the realys don’t energize.

Here’s my code:(worked before)



Hi @wmontg5988,

If you’re using a RPi, can you try reinstalling the Rasbian OS on the RPi and try again? In other words, wipe it & start from scratch & see if that works?


@jcruz, Not sure how that solves the problem when device shows online and now the ds18b20 are working properly. Buttons just are not actuating the relays and revert back to previous state. My plcduino is online just not actuating the internal relays. This problem started at the same time as the Rpi.

I have some python scripts in crontab that I would rather not go thru trying figure out what I have forgotten or lost. Starting over would be of last effort.


I have stripped down the rpi to no connections and used meter to check each gpio. Using ios app I can see the output go from high to low, low to high pressing the associated button. Web browser just hangs and won’t respond.The temperatures still respond well so that problem is gone.

I removed the PLCduino and added again after uploaded with edited code. created a button and it just won’t respond on web browser or ios. PLCduino worked really well until this last weekend, same for the Rpi3.

I am now bald from pulling hairs.


I can’t be completely sure, but I think your problem lies with these commands (looks to be one in each CAYENNE_OUT)


You should have something like

virtualWrite(mqtt_channel_number, value, "type value", "unit value")

See this post for more details

Also, your wifi SSID and password are still in that sketch you linked

No trouble with reading voltage. The channels show up & are added. I think when I have time I need to incorporate last millis() . I now think the delays I put in the loop to limit messages are preventing the relays from reacting immediately. I edited that gist to remove password, great call.



1 Like