Help with ds18b20 temp sensors breeding like rabbits!


I have a problem with DS18B20 temp sensors. There are at least 30 of them in my device tree. They all have the same serial number. when I try to remove them, the just keep showing back up! the dash board is becoming unusable because of all the effort to show the sensors.
Things I’ve tried-
1- removing them using cayenne interface- doesn’t work, they come back in 2-3 min
2- reinstalled cayenne- no go, still there.
3- selecting and removing from left pane- no go, return in a few min.

Is there a way to remove devices in a batch? One at a time if frustrating and not effective.

Problema con sonde 1-wire

Hi @stephen.delong,

Breeding like rabbits :stuck_out_tongue:

Are you using the latest version of Raspbian stretch?

Are all the widgets reading data from the sensor?

Can you trying resetting your dashboard? …Click the settings icon in top right of blue banner.



I had this bug last year. Can’t remember what exactly it was but might have been server or Jessie version. I searched posts but nothing yet. That’s a place to start. I have searched several posts but can’t find anything that I posted concerning DS18B20 sensors. resetting dashboard might just work.


Reset from dashboard. No go.
Tribles, I think there are even more now. I afraid to look anymore. This sounds like the last entry in a diary found next to a skeleton…
I have reinstalled cayenne again and no luck , yes the widgets are reading from the same sensor (based on the serial number)
I will install new version of Stretch. I’m new to the Pi/Cayanne world and I was not aware of Stretch. I will install on a card and try it out.


FIXED! Removing with iPhone worked. Not sure why it started but they are gone now.


Very odd and glad you found a fix. Please let us know if it recurs at any point. Each DS18B20 should have a unique address, I wonder if they were rotating somehow.


I have similar problem, when I used a wrong pull up resistor to the GPIO port that I conenct the DS18B20 sensor.


@rsiegel very similat to my problem… Can't remove 'dead' sensors/widgets


Try logging in with your phone and removing from there. That worked for me.


I am not sure if my issue is the same.
My fishtank underwater sensor “ds18b20” also bred like rabbits, it turned out the sensor was broken; replacing new sensor fix the issue.


Thanks for letting us know!