Work around for deleting DS18B20 1-wire temp sensor

Continuing the discussion from Bug Filed on 12-13-2015: Adding and Removing GPIO OP / DS18B20:

I had an auto discovered DS18B20 that I have since removed, but it still shows in the dashboard. Should it go away on it’s own or is this all related?

Yep, it’s related. We will release a fix for that.

You might try reseting the dashboard…click the ‘reset’ button on the blue banner of your web dashboard.


Thanks, that’s what I thought. I tried resetting the dashboard several times, along with several power cycles. I was however able to remove the sensor from the android app, and although it wasn’t removed from the dashboard when I logged in this morning, the remove button was no logger grayed out, and I was able to removed it. This may be a work around for anyone facing the same issue.

Thanks for posting workaround!

i have the same issues. Still not resolved for me.

HI @muzf.corp, welcome to the Cayenne Community.

Sorry to hear that you’re still having trouble with a DS18B20 widget stuck on your dashboard. Have you tried resetting your dashboard as bestes suggested above? To do that, browse to the device with the stuck widget, click the settings gear in the upper right, and then choose ‘Reset Dashboard’ from the menu that appears.