Newbie - Can't assign GPIO pin23


Thank you for taking the time to submit your bug/issue! Please use the points below as a guide when submitting.

I am using PI 3 Model B
|OS: raspbian 8 (debian)

I am totally new to Raspberry PI (only started 1 day ago) and I have installed Cayenne on my Raspberyy PI and able to remote control it and see CPU temperature etc. But when I try to add a simple LED device, I cannot select Channel 23, it only allows up to Channel 21

Here is what I did:
Add new
Light switch
Connectivity = Integrated GPIO
Widget = Button

But as I said above when I select Channel it only allows 5, 6, 12, 13, 16, 17, 18, 19, 20, 21

But I have an LED on GPIO pin 23 that I want to control

Thanks for your help


Hi @groovygiroux, welcome to the Cayenne Community, thanks for joining!

There should be a scroll bar on the the dropdown: my first guess is that you’ve missed it or your browser isn’t displaying it correctly?

If you still don’t see it, I would try a browser refresh. If it’s still not there, try again in a different browser to see if that resolves the issue. If that’s the case, I’d be interested in which OS/browser is having the trouble so we can investigate any errors we might have with it.

If you’re still not seeing it, let me know because that would imply something deeper is wrong here.


Yes the scroll bar was there, but the gray bar was not. The arrows at the top and bottom were light gray and not selectable.

I was using Internet Explorer, so as you suggested I tried using FireFox and sure enough I could scroll down and select Channel 23 and it works. Cayenne it pretty cool!!

Thank you and sorry to have bothered you. Next time I will always try a different browser.


No worries, glad you got it to work! When you have a moment, let me know what OS and version of Internet Explorer you had the trouble with so I can investigate a bit.


I was using Windows 7 Professional with Service Pack 1

IE was Version 11.0.9600.1854
Update Versions: 11.0.37 (KB3197655)