No Browsers working with Remote Access

Thank you for taking the time to submit your bug/issue! Please use the points below as a guide when submitting.

  • Device & model you are using (Ex: Pi 2 Model B or Arduino Uno with W5100 ethernet shield)
    Raspberry Pi3

  • What dashboard are you using? (Web, iOS, Android)
    Web and iOS

  • Please describe the bug / issue as detailed as possible. Attaching the code and any relevant screenshots would be very helpful!
    When connecting via Remote access no browsers will start. Keep getting the error:
    Xlib: extension “RANDR” missing on display “:2.0”.

tightvnc appear to be the core of the issue as vnc4server doesn’t have this issue.

Any solution?


Hi @frank.currie,

I worked with another user who encountered this issue a few days ago. You’re right, it’s because our Remote Access feature is driven by tightVNC which doesn’t support xrandr. Unless we change anything in that regard (it’s not in our immediate plans) you have a few options as a workaround.

  1. You can use one of the only browsers I’ve found that is stable through tightvnc, called hv3. See my post from that original thread:

There may be others of course. That browser did seem pretty bare bones but it behaved, at least.

  1. Work around it by connecting to your Pi with some other remote desktop/vnc software outside of the Cayenne ‘Remote Access’ feature. Like the vnc4server that you’ve mentioned, or there are many other options in the Raspbian software repository.

I’m going to try to spend some time next week to figure out if there are configuration options that you can edit on tightvnc which will allow it to behave better in the size we open into via the Remote Access feature. We don’t expose any settings for tightvnc through Cayenne, but I’m sure they are there in config files on the Pi, I’m just not sure which to change, yet. I’ll update once I know more.

Thanks. I tried HV3 and while it loaded, Java doesn’t appear to work so I’m
back at square 1.

If you want me to test something after you research please let me know.


Did you have tightVNC installed on your Pi while trying to use Cayenne’s Remote Access?


Hey @frank.currie,

I’m bumping this ancient topic to let you know that we updated our Remote Access/VNC implementation recently, and it fixes this issue with the default Pi browser (and other apps) crashing!

In addition the remote experience is improved: it now fills your browser and logs you in on the current session like you were at the Pi, so you’ll be able to see any GUI/Desktop customization and shortcuts you’ve made.