Remote Access & Web Browser

What dashboard are you using? (Web, iOS, Android)


What OS? (Jessie, Wheezy)


What Model Pi?


Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!

When I launch the browser while using remote access the browser will load and then quite before I am able to put in a url.

Do you get an error messsage?


No error is directly displayed upon the exit.

Is there a log I should check?


My apologies that you didn’t get a quicker response here. There shouldn’t be any URL you need to enter when the browser opens for remote desktop. If its closing on you, it might be an issue with your web browser itself.

All we do is open the system default web browser to a URL that displays the remote desktop in the browser window, using OpenGL, I believe. Maybe your browser isn’t set up correctly for that?

As a test, could you try to set a different web browser as the system default, then try Remote Access again? If that still doesn’t work, let me know which two browsers (and which desktop OS) you’re having this trouble with and that should help nail down the problem.

Greetings @rsiegel ,

I apologize for any miscommunication.

What I meant was that I can not use the browser that is running on the Raspberry Pi. I.e. Chromium or the browser that comes with Raspbian

When I attempt to do so the browser crashes within a second or two.

This means that I can Remote Desktop in, but can not access to interned to easily copy and paste code from tutorials.
Instead, I have to hand type all code.


Are you trying to remote VNC to a Pi from another Pi? Connecting to your local Pi will give you a tunnel of death. Have you tried just using SSH? You can use copy/paste with SSH and it is a lot faster, and once you get used to it, easier than VNC.

He is trying to copy/paste text from tutorial websites while connected to the graphical desktop via our Remote Access feature (which is indeed VNC at its core). So SSH may not be the best solution unless he wants to run the text based Lynx browser and copy that way. Which is an option, but I’m going to try and find you a better one!

@Echo – I want to let you know that I can reproduce this. When I try to launch the default Pi web browser while connected via Remote Access, it is crashing on me after a few seconds too. Very odd. I’m going to see if I can find a functional browser that behaves in this scenario that I can share with you, hang tight…

Ah, so the browser on the remote pi is crashing after it is opened. I was just reading that wrong, I thought he was trying to get Cayenne installed with the installer code which doesn’t make sense if he’s already installed it haha.

I find it much easier to modify code using SSH. Download WinSCP to transfer files between your computer and the pi and use notepad++ for editing. Using WinSCP: eDIY - WinSCP (Windows Secure CoPy) Setting Notepad++ as default editor: Change The Default Text Editor In WinSCP


Ok, so… I think after trying like 10 different browsers I have a lightweight one that seems to work under this condition! It’s called hv3. You can install from your pi command line by:

sudo apt-get install hv3

Once installed, it will run with the command


You can make a shortcut for it, of course. Be warned that this is a minimal browser, not every last thing might work, but it’s behaving far better than all of the other more mainstream ones I tried. Hopefully it will allow you to access the website you need and copy/paste code and terminal commands.

The option that @ats1080s posted probably will work better for you in the long run – establishing some way to transfer text from your main computer to the pi, so you can use modern full featured browsers to do your work. But hv3 seems to fit the bill if you’d rather work through our Remote Access feature.

Hello @echo,

I’m bumping this ancient topic to let you know that we updated our Remote Access/VNC implementation recently, and it fixes this issue with the default Pi browser (and other apps) crashing!

In addition the remote experience is improved: it now fills your browser and logs you in on the current session like you were at the Pi, so you’ll be able to see any GUI/Desktop customization and shortcuts you’ve made.

1 Like

I don’t know if there is an update to this else where but I’m having a similar but different problem. I’m able to get to the cayenne dashboard on the Pi. But the widgets either don’t update or update over a long period of time before the webpage crashes. The load on the Pi’s increases by aprox. 40% which also is slows down the data uploading to the server.

Is this a known issue and if so is there a fix to this?

This is running the Cayenne web dashboard in the Pi Chromium browser? Or some other Pi browser?

It was running on the Pi Chromium browser.