Bug Filed on 03-28-2016: Remote access problems [Fixed: suppress existing tightvnc connection]

Launching “remote access” …In my browser “ask user to press the button share the device”…

On the aspberry? On the browser? timeouted after a moment
Working on W7-64 with chrome , screenless raspberry accessed thru TightVnc…


Kaiser, welcome to the Cayenne community!

My understanding is you are on your Windows 7 computer in Chrome with the Cayenne dashboard up and trying to remote access to your RPi from there. If that is accurate TightVNC should not be needed. For example I connected to my headless unit called RPi Outside, got to the remote Raspian desktop and I don’t have TightVNC running.

If I’m misunderstanding your setup please try to clarify, but please be patient, I’m easily confused.

If you are running a X session via TightVNC while trying via Cayenne this maybe causing the problem, you might try the Cayenne connection prior to starting the TightVNC connection.

By the way all of my RPi are running headless, monitors are expensive :unamused:.

Good luck,


Your understanding is correct…
1- problem is solved.
2- problem was due to an existing automatic launch of an X session over tightvnc on port 1. Suppressing this connection cleared the problem.
3- thanks for your support (knowing that it worked for someone pushed me to investigate alternatives).

Glad to hear!

It’s always frustrating when things don’t want to work, but they don’t give you enough clues to let you know where to go to solve the problem.

Have a great day!


@Ian @kaiser.sauzet Glad this go resolved!

Sorry to intrude on this conversation, however I am having an issue using Remote Access to get into my RPi. It worked initially however I have not been able to get back in since. So I think I have the same issue with an X session since I usually do use tighvnc to remote into my Pi’s, so how exactly did you suppress the X session? Thanks, Tim

Were you able to resolve this yet? Did you try restarting the Pi and connecting first through the Cayenne remote access feature?


I have rebooted the Pi and tried Cayenne before doing anything else and the same, I get the Share the Device message and I cannot connect. The odd thing is this worked at least once so I am not sure what happened. I have several (4) Pi’s and they all are like this. I admit I have VNC loaded on all of them as that is how I usually connect to them. But on all except 1 of them I have to SSH into it and run vncserver first before I can VNC into it. So I did not think any X Sessions were loading. Something I have not done yet was to re-image one of my SD cards (and never load VNC on it) and try that, but I will if need be. I was hoping to find a fix. Thanks.

I re-imaged my Pi Zero and did not load VNC on it and I can use the Remote Access feature of Cayenne on that device. So I assume this has something to do with VNC (tightvnc) and how it is loaded on the Pi. -Tim

I spoke too soon. I cannot Remote Access into my Pi Zero any more. It worked initially after my re-image of Raspbian and I have not loaded anything else, not even VNC, and now I cannot Remote Access into it. Thoughts? Again, this is from a fresh install, why would it work initially and then stop?

hi @kaiser.sauzet can you please clear how you solved exactly the problem because i faced the same one