PIR Motion sensor trigger not working

Hi, I’m new so I’m sorry if I’m overlooking something obvious.
But I can’t seem to get any triggers to work with a motion sensor.
The sensor is hooked up fine and I can see the value change correctly.
I set up 2 triggers. The first to turn on an LED and the second to send an email. They both say “Ran 0 times” no matter what happens with the motion sensor value


I have the same issue. I’ve tried everything on both desktop and Android but no joy. Is there a resolution?

I’ll need to replicate this to confirm, it may be a bug with motion sensor as a trigger. We are fixing another motion sensor bug in triggers, perhaps it is related to this one.

If you have the time, I would be curious to know if using the ‘generic digital input’ widget would work as a trigger for the motion sensor. To do this, you would delete your current motion sensor widget and add it again as a digital input widget. If you’re able to try this out, let me know what result is :slight_smile:

I’ll get back to you once I can test this out.


Interesting, even though I’ve deleted the motion input and added the generic input(17) it still shows up as motion(17).
And NO the trigger is not working either.

I’ve hooked up the motion sensor to input 27, deleted the old generic 17 and created a new generic 27, but only the old motion 17 shows up in the list.

Now every thing is working on input 27 after I logged out and logged back in. Then the correct widgets showed up in the trigger list and the triggers could bet set.

This is what we’ve found too. There is a lag time in triggers statement that should not be there. Thank you for posting! This will help create a test case to ensure the issue is solved. At any rate, I’ll update this post and all other related when we push the fix.


To clarify, are the triggers based off motion being detected working now?


(It looks like) the GPIO 17 is fixed to motion and I could not set any triggers using GPIO 17. Neither as Motion nor Generic.
Hooking up the motion detector to GPIO 27 and using Generic digital input, as you suggested, works fine also with triggers. Maybe I had to refresh the page during setup.

We’ll push a fix for this, we found out what the issue likely is. Thanks for working through it with me! Glad we found a work around.


Hello @bestes and @scheltovandoorn, I may be of some help. I am currently using a pir sensor and receiving email with cayenne trigger system. I am though receiving them with a long delay, it takes nearly 40min to receive an email and also live reading of the state looks to be slow. Sometimes I see it sometimes I don’t, it also looks like it reads only the first trigger of a series of them.but I do receive them. I have the pir connected to an xrf wireless module which talks to a slice of radio hooked to the pi and working on UART serial pins. If this can be of any help I can make test for you.