Raspberry Pi 4 shows Error - Registration failed for invite code XYZ, closing the process

Hoping someone can help a newbie to Raspberry Pi, Linux and Cayenne.

I have an RPI 4, with 4GB RAM (64GB SD) and have installed latest Bullseye, updates etc. Eventual plan is to capture data for AC current flow thru remote motors to monitor health etc and Cayenne dashboards seem a great way to go. I am also operating this remotely via VNC.

I followed the Cayenne installation process from the web, copied, pasted and ran the two unique wget and sudo bash commands from the browser and there were no obvious errors (as far as I could see).

However my default dashboard on the web shows zero for all RPI metrics (CPU, RAM, Storage, temp etc). The Agent version on web dash shows Computer Make shows Element 14/Premier Farnell, but Computer Model shows ‘unknown’. OS Name and Version are blank.

/var/log/myDevices/cayenne.log shows a series of messages (one per minute) like “date time - myDevices - Error - Registration failed for invite code XYZ, closing the process”.

I tried uninstalling and reinstallation to no avail.

Can anyone advise please? You’ll need to spell the steps out, because I’m a newbie to Linux.

Many thanks

OK, I managed to resolve this by re-installing both Linux and Cayenne. Obviously this is a very crude solution and didnt identify the root cause or a proper fix. But it worked.

1 Like