Restart


#1

Hello
I have problem on iphone somtimes when i login to app my devices is offline when i restart raspberry pi is agian online ? any sugestion or it is possibele resetart script once a day ??


#2

Are you using the Pi Agent to connect? If so, can you post your log file tail -f /var/log/myDevices/cayenne.log


#3

2019-01-10 07:31:09 - myDevices - INFO - Sensors info:
2019-01-10 07:31:13 - myDevices - INFO - Send changed data: [{‘sys:cpu;load’: 6. 5}, {‘sys:cpu;temp’: 62.3}, {‘sys:ram;usage’: 409141248}, {‘sys:storage:/;usage’ : 3565936640}, {‘sys:net;ip’: ‘20.0.0.126’}, {‘sys:net;speedtest’: 1.74575367241 10692}] + sys:gpio
2019-01-10 07:31:24 - myDevices - INFO - Sensors info:
2019-01-10 07:31:28 - myDevices - INFO - Send changed data: [{‘sys:cpu;load’: 5. 3}, {‘sys:cpu;temp’: 61.762}, {‘sys:ram;usage’: 409014272}]
2019-01-10 07:31:39 - myDevices - INFO - Sensors info:
2019-01-10 07:31:44 - myDevices - INFO - Send changed data: [{‘sys:cpu;load’: 5. 4}, {‘sys:ram;usage’: 408985600}]
2019-01-10 07:31:54 - myDevices - INFO - Sensors info:
2019-01-10 07:31:58 - myDevices - INFO - Send changed data: [{‘sys:cpu;load’: 5. 6}, {‘sys:cpu;temp’: 62.3}, {‘sys:ram;usage’: 409124864}]
2019-01-10 07:32:09 - myDevices - INFO - Sensors info:
2019-01-10 07:32:13 - myDevices - INFO - Send changed data: [{‘sys:cpu;load’: 7. 7}, {‘sys:cpu;temp’: 62.3}, {‘sys:ram;usage’: 411410432}, {‘sys:storage:/;usage’ : 3565936640}, {‘sys:net;ip’: ‘20.0.0.126’}, {‘sys:net;speedtest’: 1.74575367241 10692}] + sys:gpio
2019-01-10 07:32:24 - myDevices - INFO - Sensors info:
2019-01-10 07:32:28 - myDevices - INFO - Send changed data: [{‘sys:cpu;load’: 6.6}, {‘sys:ram;usage’: 412282880}]
2019-01-10 07:32:39 - myDevices - INFO - Sensors info:
2019-01-10 07:32:43 - myDevices - INFO - Send changed data: [{‘sys:cpu;load’: 5.1}, {‘sys:ram;usage’: 412028928}]
2019-01-10 07:32:54 - myDevices - INFO - Sensors info:
2019-01-10 07:32:58 - myDevices - INFO - Send changed data: [{‘sys:cpu;load’: 6.8}, {‘sys:ram;usage’: 412024832}]
2019-01-10 07:33:09 - myDevices - INFO - Sensors info:
2019-01-10 07:33:13 - myDevices - INFO - Send changed data: [{‘sys:cpu;load’: 5.8}, {‘sys:cpu;temp’: 62.3}, {‘sys:ram;usage’: 412504064}, {‘sys:storage:/;usage’: 3565936640}, {‘sys:net;ip’: ‘20.0.0.126’}, {‘sys:net;speedtest’: 1.7457536724110692}] + sys:gpio
2019-01-10 07:33:24 - myDevices - INFO - Sensors info:
2019-01-10 07:33:26 - myDevices - INFO - Checking for updates…
2019-01-10 07:33:28 - myDevices - INFO - Send changed data: [{‘sys:cpu;load’: 5.6}, {‘sys:cpu;temp’: 61.762}, {‘sys:ram;usage’: 412377088}]
2019-01-10 07:33:39 - myDevices - INFO - Sensors info:
2019-01-10 07:33:43 - myDevices - INFO - Send changed data: [{‘sys:cpu;temp’: 62.3}, {‘sys:ram;usage’: 412012544}]
2019-01-10 07:33:54 - myDevices - INFO - Sensors info:
2019-01-10 07:33:58 - myDevices - INFO - Send changed data: [{‘sys:cpu;load’: 6.1}, {‘sys:ram;usage’: 412393472}, {‘sys:storage:/;usage’: 3565940736}]


#4

can you try refreshing the cayenne app device list by scrolling it down.