RPi 3B and 3B+ stretch install issue


I have tried to install Cayenne on two of my RPi model B. Since I am booting from USB instead of SD card I decided to try to install if the SD card was used. Everything went perfectly. So I am puzzled to why it freezes when I use the USB boot. The USB and SD card are the same size 32Gb and even tried a 128Gb without success. The following are what my settings and system are.

df -h
pi@raspberrypi:~ $ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/root 27G 4.6G 21G 18% /
devtmpfs 460M 0 460M 0% /dev
tmpfs 464M 0 464M 0% /dev/shm
tmpfs 464M 13M 452M 3% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 464M 0 464M 0% /sys/fs/cgroup
/dev/sda6 68M 22M 47M 32% /boot
tmpfs 93M 0 93M 0% /run/user/1000
/dev/sda5 30M 446K 28M 2% /media/pi/SETTINGS

cat /etc/os-release
pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME=“Raspbian GNU/Linux 9 (stretch)”
NAME=“Raspbian GNU/Linux”
VERSION=“9 (stretch)”

and this is where it stops in the installation


  • set -x
  • exec
    Thu Apr 5 17:41:31 ADT 2018 Installing myDevices agent

Always stops at this point and remains here forever. I let it try up to three days.

Is there any ways we could have this installed on my external USB drive which I would really prefer.


These threads might help you out: