Raspbian Jessie boot from USB Stick and Cayenne Install

Hi, all!
Is it possible to install the Cayenne in the case of Raspbian booting from USB Stick. In that case The OS itself is operating normally, but installing Cayenne I did not succeed. Stops at step install the agent and all …

The same story using a loader Berryboot.

It all started with the fact that I have worked Cayenne with a temperature sensor less than a day, and less than a day. At some point, the system stops responding and went offline, after reboot (power off) showed damaged areas (blocks) microSD card. So I decided to test the ability to install Cayenne with Raspbian booting from USB.

Another problem - do not understand the work of the Android mobile application. Very often tells me when the application starts - that the remote device is disconnected. Although information from the sensor, CPU usage and memory I see. Or the simultaneous operation of applications and shev interface is not permitted?

I would be glad of any information and assistance. Thank you (sorry for bad English).

Hi @vadzzsheriff,

That’s great that you got a temperature sensor going in less than a day! Cayenne team loves to hear this.

I’ve actually attempted to boot Raspbian from a USB stick. So is Raspbian installed and running on your Pi?

Regarding the Android app, does the error message prevent the app from working? Or does it just appear quickly and then go away?


Hi @bestes,

I think that I create a separate post about mobile application, which will describe the bugs noticed by me. It works on my phone, but not stable (Moto G).

OS image I writed on USB stick (8GB). In the network a lot of options and instructions on how to install the OS on USB Flash drive, I tried a few options. All is well, the OS works fine. Installing Cayenne stops at the beginning of the agent installation.
For me, at this stage it is the most important point - installing Cayenne on Raspbian running from USB Stick.

I understand what Cayenne will not working with Berryboot bootloader because Berryboot uses its own kernel…