Server error


I have problem in connecting arduino w5100 shield it show’s serial monitor
dhcp server error. And
Please help me to solve this problem as quick as possible
Thank you


The arduino ide show the dhcp failed in w5100 Ethernet shield so please help me to solve this problem



Can you share the sketch you’re using so we can verify? You can delete the private token when posting it, we don’t need to see that.


Her is the sketch



I don’t see any attachment. I think if you are replying to the forum by email you can’t add attachments to posts that way. Apologies. You can either click the ‘Visit Topic’ button to go to the forum to make a post with attachment there, or you can email me at


Hi again, thank you for the sketch (I got it via email). No problems there, looked like a typical sketch for connecting an Uno / W5100 combo.

This ‘DHCP Failed’ error can be seen for lots of reasons, here are some things to try based on scenarios we’ve encountered in the past:

  • If you have some other device to plug into the same Ethernet cable (like a laptop or desktop computer), try that and verify it can get an IP address assigned via DHCP. If it can’t, this could be an issue with the cable or with your router assigning IP addresses via DHCP

  • We know that sometimes having a microSD card in the 5100 shield card slot can cause this error due to hardware limitations. If you have one inserted, try taking it out, power cycling the Arduino, and trying again

  • Do you have an official Arduino shield? There are some reports of Chinese cloned shields that fail in this regard due to using an incorrect resistor:
    That thread also has some test code separate from Cayenne that you can use to sanity check that your Arduino can make a network connection.

  • See the picture in this post to see if perhaps your Ethernet socket and USB socket are touching and causing a short :fearful: : Connecting Issue with Arduino uno and Cayenne Via Ethernet Shield W5100

  • Verify you are connected to a network that has a router which can assign an address via DHCP, not just a switch

  • Verify you’re not on a network that requires additional authentication to log in to get an internet connection, like some corporate, university, or public networks.

  • You’ve probably tried as much in all this time, but for some users, a power cycle to the Arduino was enough to resolve this. :slight_smile:

If none of the above does the trick, let us know a little about the network you are using. What does the ethernet cable you are plugging into the Arduino route to on the other side (router, switch, wireless bridge, etc)

Cant connect to cayenne
Arduino Mega+ ethernet shield not connecting to Cayenne dashboard
Connecting of device

Nun of the above should not working
Is there is anyway to connecting arduino with cayenne dashboard.and I have
tried with another Ethernet shield and new Ethernet cable .it show’s only
Is there is possible of settings in the modem should happen.

Adding the pwm control to the raspberry pi widget .Without using any
extension bord is possible.if it is possible connecting arduino with
raspberry pi serial dashboard in raspbin .

Please help me to solve this problem
       Thanking you


give me full detailed step by step connection procedure about using
esp8266 as arduino wifi shield with codes.

Then the detailed connection about adding mqtt in nodemcu to
add wiget in dashboard.
Thanking you


The widget should not adding in Cayenne mobile app Android


give me full detailed step by step connection procedure about using
esp8266 as arduino wifi shield with codes.

Then the detailed connection about adding mqtt in nodemcu to
add wiget in dashboard.
Thanking you


Give this a try and let me know if that doesn’t help.


Cayenne dashboard and Android app is not working check the problem
Thanking you


Looks like our production service is indeed down. Our engineering team is on it and we should have an update soon.


And we should be back in business. Apologies for the short downtime, and thank you for alerting us!


Cayenne Android app is not working check this out thank you


Esp8266 mqtt shudule and trigger alart not showing in Android app


I am experiencing the “server error” in the Android app. I notice the behavior started happening about 2-3 days ago, it does not load the Raspberry Pi 3 that i have configured into the app. If i close the app and restart, it will sometimes show up, sometimes it takes two or three restarts.


Server error please check Android app in not working


@sugumarvidyasagar @walters

I’m not aware of any server instability over the weekend, perhaps this could be some state on your account that the Android app isn’t handling well? Try clearing the app entirely with Force Stop > Clear Data in the Android App Manager. If the error persists, could you share your account credentials via private message so I can try to reproduce on my end/look for anything strange on the individual accounts?


@sugumarvidyasagar @walters

Just wanted to update my previous post now that I have more information. It looks like our cloud server is returning intermittent 400 and 500 errors that are likely the cause of the ‘server error’ messages you’ve been seeing. We see them now on our end as well, and have our IT investigating the root cause. I’ll update here as soon as we believe this to be stable once again. Thank you for your patience.


We now believe the root cause of these errors to be fixed. Let me know if you see the Server Error message any more in the next hours or days.

1 Like