Shceduler troubleshooting


#21

Hello
I also add notification mail to all my schedules, but none of them run, i have no email in my inbox.
Scheduling still not working.


#22

Success
Today i deleted again all my schedules and recreated them. All of them work now. I will check again tomorrow.
Regards


#23

Thanks for the update. Glad to hear it is working today. Definitely let us know how it goes, as you should not have to delete and recreate these events with any regularity, this should only be because of issues porting events from the old system.


#24

Ok … so I read this and thought I should check my schedules and they are not working at all either! I have put in a test scheduled event with an email trigger but I get no email so I’m guessing the problem is at the Cayenne end?
Any thoughts?


#25

Hello @rsiegel
I placed the notifications but till this morning at the time of writing this, nothing functions. Would it be ok to delete everything and start all over again?


#26

Hi @rsiegel


#27

Well today unfortunately none of the schedules worked and no notifications have been sent.


#28

Update: Yesterday I plugged in my nodemcu and D1 (same device ID but did not put them online simultaneously of course).Scheduling does not work. Sketch nor schedule was changed. When I added mail notification I did not receive mail.

Scheduling worked well previously (after your upgrade and I also recreated events at that time) Manual operation from my iphone dashboard still works fine.


#29

My scheduled event worked fine tonight - will check again in the morning.
Thank you.


#30

Scheduled event ON and OFF worked perfectly this morning. I have an Arduino/W5100 combination.
Thank you


#31

Hello,
Scheduling still not functional in my boards.


#32

I think this is a good troubleshooting step as from the date on your screenshot, the event appears to have been created in the old system. Again, you shouldn’t have to worry that old events are no longer valid, but it is worth re-creating it to see if that improves behavior. I set up a similar schedule to yours on my end and its working OK (at least, the first occurrence, I have not waited a day yet)


#33

@ufrtgr and @ihatespam,

It sounds like this must be on our end, as I’ve run tests with scheduled events where the device isn’t even connected to Cayenne, and it still dutifully sends out notification emails at the time of each event. I’d expect you to get the emails when the time hits, regardless of any wiring or device connectivity issues.

I’ll talk to our dev team to see if they can locate anything specific with your accounts. I know you’ve provided some of this information earlier in the thread, but just so I have it in one place, can you let me know:

  • Device type(s) having trouble with Cayenne scheduling
  • Connection type to Cayenne (i.e. Raspberry Pi / Arduino / MQTT (Bring Your Own Thing) / LoRa)
  • When was the scheduled event created (estimate is fine, just to make sure its not older than June 2017 when we released the new scheduler)
  • What was the scheduled event supposed to do (i.e. activate a relay, reboot a pi, etc)
  • Is there any recurrence/repeat on the event – if so, what settings specifically (‘Every 1 day’, 'Hourly every 2 hours, etc)

#34

Thanks, the project details are here Controlling cheap 433MHz Switch units with Wemos D1 and Cayenne

I’m using 3 devices (not at the same time, just flashed them with the exact same sketch to find out if they work).

The boards are Wemos D1, D1 mini and Nodemcu Lolin.

I used hourly and daily schedules for testing

Last weekend I created a new schedule which did give a mail notification once or twice. All schedules are created in the new scheduler (June)


#35

Hello,
I am using the following boards.

  1. Arduino Uno +W5100 Ethernet Shield
  2. Node MCU
  3. Arduino Ethernet
  4. Wemos D1
  5. Arduino Yun

Arduino Yun is operating in a different account. All boards are setup with daily schedules to execute and triggers. All my schedules recreated in June, 2 or 3 days ago. At the moment scheduling is not running.


#36

Hi @rsiegel
Thanks for your efforts so far. I’m currently connected to an arduino mega and an Ethernet shield w5100.
Here are the problems I have so far;
1)the arduino is connected to internet and everything is ok, if I activate any light o relay contact it responds immediately, which means it’s working good.
2)l have two schedules so far one on aquarium lights on/off and the other balcony lights.
The notification mails react now perfectly but the led indicators on the program remain off. It sounds strange but that’s what happens.

Eric


#37

Hi @njueric @ufrtgr @ihatespam,

Just wanted to check in again here. How are the scheduling events working for you?

~Benny


#38

Hello, mine schedules in two different Arduino boards do not work at all.
Regards


#39

Hi @ufrtgr, sorry to hear that you’re still having trouble with this feature. Could you let me know some examples of the types of scheduled events that aren’t working for you? I.E. what is the expected action when the event occurs, are these once-only or recurring events (and if recurring, what settings). If you add a notification to these events, is it received at the expect time?


#40

Hi @njueric @ufrtgr @ihatespam,

I hope all is going well. I’m going to move this thread to resolved since we’ve had no widespread complaints about the new scheduler. Certainly feel free to post here if you want to troubleshoot some more or create a new thread for your specific issue, and share as much detail as you can about the scheduled events so we can try to reproduce with our QA.

Thanks for your patience while we wrote the new scheduler engine to improve this feature!