The scheduler doesn't run


#1

Hi,

I’m trying to set up a project for my daughters Rabbit House, to get her involved and understand how useful it can be to know how to make some own projects.

My plan is to schedule the lights and measure the temperature in each cage to start with and thereby replace some Telldus Live stuff.

My platform is a RPi B+, and I have at the moment 4 relays connected. I am able to control each relay on/off from my mobile or my computer, and it works every time.

But when I try to schedule on/off and trying to use the scheduler, the only thing that does work is the notifications that I get by sms and email. It doesn’t matter if I schedule it in the app or the ordinary dash board on my computer.

Another question; if some of the relays are in the ‘on-state’ and the RPi is rebooted; will the relays go to the same state when the RPi is up and running again?

Thanks in advance for your support guys!

Stefan


#2

Hello Sir,
I tested the scheduler with my raspberry pi 3 and it is working as normal. Can you check which Kernel you have installed on your raspberry with the following command: uname -r

To the other question about the relays: The developer team is working on the function called “last state” as I know. This function will do this thing that you ask for. Now if the raspberry is rebooted, the relay will turn of and remain off until you switched it on ( it the relay is ACTIVE HIGH). If it is ACTIVE LOW - it will be triggered on.

Greetings.


#3

Hello,

The Kernel version is: 4.4.50+.

Thnx for the information regarding the relay state.

Best regards,


#4

Hello,
The scheduler should work. Can you restart the device and try again ?


#5

Hi,

Okey, I’ll do that!

One question: will I loose the on/off-events that I have scheduled? Do I need to re-schedule all events after the reboot?


#6

Hi,

Still no change; what can be wrong? Are there any logs to view?


#7

As far as the last state goes with using relays, I have found that if I’m employing a relay and I need to use invert then on reboot those gpio all go high.


#8

Is your scheduler running?


#9

Hi,

It seems to work occasionally, but I have forgot to add a notifier.

I changed it now so I will be notified next time.

I am not at home this week so I have to rely on the dashboard in my phone.

Best regards
Stefan


#10

Hi again,

The problem’s back! The scheduler doesn’t run anymore.

It stopped when I moved my RPi to the place where it should be, and when I started it again the scheduler didn’t begin to work.

It’s possible to control all four relays from the app in my phone, and they change state within a few seconds.

Can you do anything to get it running again?

Best regards,
Stefan


#11

I will test now my scheduler!


#12

It is working fine!


#13

I’ll see what will happen tonight. I did some changes in my schedule last
night.


#14

The scheduler didn’t work tonight.


#15

Was the schedule to turn off the relay, notify you via email/SMS, or both? If both, did all parts of the scheduled event fail, or only the relay part?


#16

Hi,

The scheduler worked when the relays turned off the lights tonight, but it
didn’t turn then on.

I won’t be home tomorrow so let’s give it a try once again; I’ll let you
know on sunday evening if it works then.

Best regards,
Stefan


#17

Thanks @stefanspanberg, we really appreciate you helping to troubleshoot.

~Benny


#18

Mine schedulers are only for email notifiers setup and they work all. Maybe the problem is not with the platform but with something else…


#19

Hi again,

The situation remains the same; the scheduler won’t switch on my relays, but it switches them off!

Neither notification by email or sms works; no messages received.

Any suggestions to get on with this?

Best regards,
Stefan


#20

Hi @stefanspanberg, I apologize for the trouble you’re seeing. Since you’re not even seeing the email/SMS notifications, it could be some issue on our end. I’d like to try and replicate this exactly tonight on my end since I ran across an odd but very specific (unrelated to this) scheduler bug today. Maybe it is something in the exact settings of your events?

Could you tell me (really a screenshot would be great), the details to both your on/off events? I’m interested in the exact time, timezones, recurrence, everything. If its too big a pain to block out your email for the forum you can feel free to send it to support@mydevices.com instead. Thanks again for your help in troubleshooting.