Triggers don't work


thank you for your swift response. Unfortunatelly the “device” related triggers are still not working. There is no problem with “notify” related triggers/actions. But simple “if btn pushed” than “light on” is not working eventhough I can see the Btn value changed from 0->1.


Looks like this was it, I can reproduce us rendering poorly there:

In my test it does work if you ignore the box and drag onto those words I’m pointing at. You might want to consider using another browser like Chrome or Firefox for Cayenne until we resolve this though, there might be other weirdness with Edge on other dialogs…

I’m not seeing this behavior on my test pi’s – I set up some buttons to trigger another button to turn on a physical LED and they fired OK. Now I am kind of interested in the uptime of the Pi and where your RAM level currently sits, I wonder if you’re getting odd behavior due to resource consumption on the device.


Sry I don’t have access to PC and so I’m attaching screenshot of the dashboard where the current utilization can be seen.

Is there any debug I can turn on?

There isn’t any debug in the Android app itself, but I am curious if you could run a quick test for me. Can you open the Triggers tab (the icon with the Arrow in the circle on the top of the screenshot you have there). I’m curious if a full list of your triggers displays, or if you get an error message.

@rsiegel that’s weird. In mobil app I receive error message when I’m trying to display available triggers which says me there is no trigger configured. But in web I can see all my triggers configured in proper way.


@michal.z4nd4r I think I see what’s up here then. We made a fix to our server last week to resolve some issues that had made the Android app unstable in the last month. While that fix is live and does not require a new Android build, we’ve found that for many users it was necessary to reset the app data for the Cayenne app in order for the fix to appear.

I think this is a trouble since your triggers are not missing, just failing to load from our server.

Try locating the Cayenne app in your Android Application Manager, then ‘Force Stop’ and finally ‘Clear Data’. You’ll need to log back into the app on re-launch, but it should force to the app to load all fresh data. Have a look for your triggers again to see if they are present.

@rsiegel to be honest with you I don’t believe this is the root cause of the issue as the issue is “triggers coupled with devices aren’t working” and not “triggers dissapeared in mobile app”.

I have performed the proposed steps anyway Force stop && Clear Data. As I expected “triggers coupled with devices” are still not working. For my suprising the triggers didn’t appear in Android App as well (once more time this is not the main issue).

Don’t hesitate to ask for some debug/packet capture etc.

Glad to help to resolve the issue.


Thank you for your help. It is working.
When will be available other widgets like “meter”?

Tudor Teodorescu

@tudor.teodorescu In the last meeting we had about these widgets, I was told Q2 of 2017. We’ll be sure to announce on the forum when these are released.

1 Like


Got it. I only asked about the Android app triggers page as this looked like a symptom of that issue, plus you had mentioned you didn’t have a PC available earlier in the thread. I see now that you do. :slight_smile:

I wonder if you could run a test, since I am seeing triggers working on devices in my test setup. The purpose here is to eliminate any potential wiring or device issues, keep the whole test inside of Cayenne. On the web, can you create 2 Light Switch widgets from Add New > Device/Widget > Actuators > Light > Light Switch? They don’t need to be connected to any sort of real-world device, just pick two unused digital pins on your Raspberry Pi.

Once they are created, make a trigger: if Light Switch A is ON, then turn Light Switch B ON. Save it, then turn A on. If B switches to ON, then it establishes at least for a simple case, you can run triggers coupled with devices. Then we can start looking at your specific triggers/widgets/wiring for the issue. If B never comes ON, I would be interested in your account login for investigation. Only if you are comfortable, and shared privately, of course.

@rsiegel good thinking indeed. I performed the test for you. Result:

Mobile App: I have alredy 4 LED physicaly connected to my PI. I have set up trigger (in web env.) as you suggested. If LightA is on then LightB goes on as well. However I can’t see the triggers in mobile app (the same error like before) I can see in the app the second LightB went UP as well. As I’m not physicaly by the PI at the moment I can’t confirm the LED start shining as well. I would guess it did as I tried it last time and it works like charm

Web App: Don’t know why, but here is the situation quiet different. When I’m trying to turn on ANY LED the “progress animation” start circling but it won’t finish. But in web I can see my triggers.

Such a strange behaviour, isn’t? I really believe the physical wiring is OK as I tested it many times from web and the Buttons, LED, motion sensor, DS18b20 all it works like charm.

PS: I might have a theory why is not working and I will clarify it when I come back to my RPI.


@rsiegel ok I’m back to my RPI. I have done simple test as you suggested and I could see that LED comes up and down without any problem. But my “old” set up trigger simple didn’t work.

I have performed simple task: delete the old triggers and make exactly the same with the same conditions etc and I confirm it is working now like a charm :slight_smile: eventhough triggers are not showen in MobileApp.

I hope also my (and I suppose not only mine :wink: ) issues like “MQTT” issue or “Project dissapearing” issue will also removed.

Keed tunned.


This is excellent news, and thanks for running my test to help confirm. I would like to investigate/see if I can reproduce the issue on my test Android devices. Any chance you are up for sharing your account login? I won’t touch anything when I’m in there.

The projects issue we are well aware of. Unfortunately the fix is delayed until next week, but your projects are in there and will display again as soon as we push it.

@rsiegel no problem to share my login credentials. Let me change them and I’ll send you PM. :slight_smile:


I want to share in the thread what I found in investigation of Michal’s account, in case anyone has a similar issue and finds this before we fix it.

It looks like the Android app triggers list will be blank if you have an MQTT based trigger on your account. This is a bug in the App – while it is not yet expected to support MQTT, it should be able to behave on an account with MQTT devices and triggers without choking on the data.


It was good troubleshooting indeed. I can only confirm what @rsiegel has already mentioned. After I have deleted the MQTT coupled trigger, the list of triggres already appeared in Android App.


I did want to add that we’ll be pushing an update to the Cayenne Android app in the next few weeks that will resolve this, so that you can have MQTT and other triggers on your account and still use the Android app.

And then soon after that, we’ll introduce MQTT support to Android, so there will be more feature parity between the mobile app and web.

Hi @michal.z4nd4r (and anyone else reading),

I wanted to update the thread to let you know we released a new Android build (1.2.8) yesterday which fixes the issue where the MQTT trigger could cause the Android Triggers & Alerts tab to be blank. So now you can have both types of triggers on your account and still use the Android app OK. :slight_smile:

Please note that the Android app still does not have MQTT/LoRa support yet (we’re working on it for the next release). So while you’ll be able to see the trigger, if you try to interact with it, you will get a dialog explaining that you can’t interact with it on the Android app. But it won’t break the other triggers from displaying anymore.


Were you able to support LoRa?
I got a payload from TTN but it does not work as a trigger.
I am measuring the distance with the LoRa ultrasonic sensor.
There is no problem with ESP 8266 stand-alone operation with the schedule function.