Triggers suddenly not working

Thank you for taking the time to submit your bug/issue! Please use the points below as a guide when submitting.

  • Device & model you are using (Ex: Pi 2 Model B or Arduino Uno with W5100 ethernet shield)

  • What dashboard are you using? (Web, iOS, Android)

  • Please describe the bug / issue as detailed as possible. Attaching the code and any relevant screenshots would be very helpful!

Hi @gregxl510900 ,

It would helpful to know what device you were using. Raspberry Pi?


Unfortunately the same problem is present in my device rpi 3
triggers are not working

Yes, we are aware we will fix this when we have some time. Good news is, we are working to transition to a much more reliable triggers & alerts engine very soon…


1 Like

Hey Benny, any news on this issue?
Some idea when it can be fixed?


1 Like

Problems with triggers, they are not working see screenshot. Who has a solution?
I see the description “null” and also “Ran 0 times”. I have no clou whats going wrong.

I am also facing these problems with my raspberry pi 3 model B
any idea when it is going to be fixed

Same issue here. Raspberry Pi 3 Model B with motion sensor tripping a light. It used to work.

Same here. I have an Arduino clone (Elecrow board, A7 with 32u4) using GPRS to connect to the MQTT Broker. Data is going through, On-line / Off-line can be seen immediately, but NONE of the two-state triggers are working. I didn’t try the analogue ones because I don’t need them now.

the problem persists, I can not use the trigger in any way, neither with digital signals, nor with analog signals

@wwerner can you try again with you Raspberry Pi triggers? You may need to delete / recreate.


I deleted the triggers, but it did not work, deleting the project and creating a new one can solve the problem?

I deleted the project and created a new one, it also did not work

Can one developer react please?
Is it a small or big problem, and what is the expected resolve time or period?
Triggers still not working.


I deleted the trigger and re-created it. I also rebooted the Pi. The light is still not activating with the motion trigger. The motion sensor seems considerably less responsive than before the changes as well. I have not made any adjustments to the motion sensor.



@bestes I also deleted and recreated triggers twice for good measure but to no avail.


You guy’s had this spot on before MQTT, why mess it all up.