Unable to add any new device


Hi, I am unable to add any new device from Web. iOS is working
when click on Add New > Device/Widget - I have no action. Tried Chrome, Firefox, IE, all with the same problem.

The other tabs / Add new - Event, Trigger and Project are working fine.

  • Device & model you are using (ANY new sensor)

  • What dashboard are you using? (Web)

  • Please describe the bug / issue as detailed as possible. Attaching the code and any relevant screenshots would be very helpful!



Hello and welcome to the Cayenne community. What error do you get ?


Hi Ognqn,

I have no error. It doesn’t do anything when I click on the button, add a new device.

I did it through iOS app, but WEB isn’t working to me.

Thanks & BR | Martin


It is very strange. What versions of the web browser do you use ? Are they the latest? Sometimes I have problems with mozilla.


Yes, it was working to me before, but not today.
Tried from several machines as well.

Now it started to work again. I tried 2 machines before both Firefox 54.0.1 (32-Bit) and Chrome Version 59.0.3071.115

Now it works also on Firefox, thanks for your help.

BR | Martin


I actually had the same problem, started working on its own after I had the dashboard open for about 5 minutes.


@martin.kostial @adam

After conferring with our IT this morning, it looks like this was an issue on our end that he’s now made a fix for. I was reproducing it too for a short period after login, and that is resolved now for me.

I know you both mentioned that you got it to work again even before this fix, but the root cause should be resolved now. Please let me know if the issue pops up again.


Hang on, it might not be entirely fixed just yet. We’re still seeing some errors in our test, and will continue to investigate. I’ll update as soon as I know more.


Ok, we now believe it to be resolved properly, please let me know if you see this failure of the Add New > Device/Widget menu to load anything in the future. If you do, I’d be interested in the output from your browser console. If you need help to gather that, let me know which browser you are using.