Unable to connect BMP180

I have recently installed Cayenne. Before I installed, I connected my BMP180 sensor, and ran the following, “sudo i2cdetect -y 1” which listed the address as 77 (therefore the Pi could ‘see’ the sensor.

After installing Cayenne, I tried to add the BMP180 as a sensor, I received an error message.

I tried again the ‘i2cdetect -y 1’ command, and got the following message “Error: Could not open file ‘/dev/i2c-1’ or ‘dev/i2c/1’ : No such file or directory”

Has Cayenne moved or overwritten the i2c stuff?

Please go easy on me, I’m a little new to IOT stuff


An update…

I have just made a new copy of Rasbian (stretch) on another micro SD card, installed I2ctools, and done a i2cdetect. The new install worked and found a sensor at address 77.

The plot thickens.

When I get time, I’ll reinstall a program that reads the sensor (outside of Cayenne) just for peace of mind etc…

Any ideas?

Further update…

I have not had time to try and find and install a program to test further, but I have installed Cayenne on the second micro SD card. Then ran i2cdetect, this time it still finds the BMP180!

But, trying to add it in Cayenne still comes up the original fault as in my first post.

I’m thinking that the BMP180 must be working (to some degree, as i2cdetect can find it)? Is Cayenne looking for it at address 77?

Any ideas anyone?

Maybe it was a typo, but the first command you have sudo i2cdetect -y 1 and the second i2cdetect -y 1 Without sudo you will get the error message you posted since it does not have access. Maybe there is a bug with this sensor again? From everything you have posted it should work. tagging @bestes and @rsiegel

After some testing, i got a second sensor, this worked so i guess the original was faulty?!

1 Like

Thanks for posting back! I’ll mark this as solved.