Unable to reach arduino.mydevices.com:8442 - putty advice

#29

So if it continues to say connecting, you can change it back, it’s not a dhcp issue.

What wifi shield model are you using?

Can you share your sketch so someone else can verify?

Cheers,

Craig

#30

Ok thank you. I use the normal wifi shield from arduino .

I change only Wifi account and token in the sketch

/*
Cayenne WiFi Example

This sketch connects to the Cayenne server using an Arduino WiFi shield
and runs the main communication loop.

The Cayenne Library is required to run this sketch. If you have not already done so you can install it from the Arduino IDE Library Manager.

Steps:

  1. Set the token variable to match the Arduino token from the Dashboard.
  2. Set the network name and password.
  3. Compile and upload this sketch.

For Cayenne Dashboard widgets using digital or analog pins this sketch will automatically
send data on those pins to the Cayenne server. If the widgets use Virtual Pins, data
should be sent to those pins using virtualWrites. Examples for sending and receiving
Virtual Pin data are under the Basics folder.
*/

//#define CAYENNE_DEBUG // Uncomment to show debug messages
#define CAYENNE_PRINT Serial // Comment this out to disable prints and save space
#include <CayenneWiFi.h>

// Cayenne authentication token. This should be obtained from the Cayenne Dashboard.
char token[] = “Token”;
// Your network name and password.
char ssid[] = “NetworkSSID”;
char password[] = “NetworkPassword”;

void setup()
{
Serial.begin(9600);
Cayenne.begin(token, ssid, password);
}

void loop()
{
Cayenne.run();
}

#31

As written, that sketch will not compile. Try this:

/*
Cayenne WiFi Example

This sketch connects to the Cayenne server using an Arduino WiFi shield
and runs the main communication loop.

The Cayenne Library is required to run this sketch. If you have not already done so you can install it from the Arduino IDE Library Manager.

Steps:
1. Set the token variable to match the Arduino token from the Dashboard.
2. Set the network name and password.
3. Compile and upload this sketch.

For Cayenne Dashboard widgets using digital or analog pins this sketch will automatically
send data on those pins to the Cayenne server. If the widgets use Virtual Pins, data
should be sent to those pins using virtualWrites. Examples for sending and receiving
Virtual Pin data are under the Basics folder.
*/

//#define CAYENNE_DEBUG         // Uncomment to show debug messages
#define CAYENNE_PRINT Serial  // Comment this out to disable prints and save space
#include <CayenneWiFi.h>

// Cayenne authentication token. This should be obtained from the Cayenne Dashboard.
char token[] = "AuthenticationToken";
// Your network name and password.
char ssid[] = "NetworkSSID";
char password[] = "NetworkPassword";

void setup()
{
	Serial.begin(9600);
	Cayenne.begin(token, ssid, password);
}

void loop()
{
	Cayenne.run();
}

Also, we need to know the specific model number of the Wifi shield as there are many of them, plus a few Chinese copies :slight_smile:

Cheers,

Craig

#32

R3 Arduino Shield WiFi-Shield 65198 90-A2-DA-0F-A9-
Thats the information on the Shield.

Was my mistake by the copy , skatch is the same .Tried and on the dashboard : waiting for board to connect

#33

I used it before with usb serial connection and that was ok but with wifishield no connection to dashboard maybe this is the problem

#34

I have read that you may want to try a better quality USB cable or external supply with these boards.

Also, there is a known issue as well with the firmware, and perhaps the way you set the server. I’ll see if I can find a workaround if an external supply does not work.

Cheers,

Craig

#35

I connected the arduino with a 12 V power supply , but didn´t work. .
The firmware from the wifi shield? Which server you mean?

#36

Yeah, the shield firmware. How old is it?

How you pass the Cayenne server address to the begin function is what I was talking about. I’m not sure the Cayenne lib does that overload though.

See here:

Craig

#37

I don´t know the exact prduction date of the shield on the board is no date but bought it for one week from a big electro shop .

I use an new USB cable , use additional 12 v power supply .

I installed arduino IDE , cayenne library . Then I took the sketch for WiFISHIELD from cayenne homepage changed only the token ,wifi name and password. uploaded the sketch . Then I saw what serial monitor told me. And everytime :

[[490] Connecting to FRITZ!Box6490Cable…
[10492] My IP: 192.168.177.46
[10492] Connecting to arduino.mydevices.com:8442
[21510] Connecting to arduino.mydevices.com:8442
[31513] Connecting to arduino.mydevices.com:8442

I read the link which you posted but everything I tried didn´t work. :frowning:
Don´t know what I did wrong

#38

I tried it with an Raspberry 3 B and this works , so it must be something on the arduino

#39

Good that you were able to connect. Raspberry Pi uses a different server and port though.

Either the board is goofy or you still have network blocking issues around 8442.

Can you try connecting your Uno using the standalone serial sketch. This will see your pc connecting to 8442 instead. Is your PC on wifi, or plugged into your router?

Cheers,

Craig

#40

I tried it with arduino mega and arduino leonardo . serial usb connection is possible but with the wifishield no connection to mydevice server. I think the problem is the port because I have a Dual Stack light router connection, but can´t imagine why there are no problems with raspberry port .

#41

I don’t have your board, so can’t determine what the issue is.

Could be the Blynk driver, could be your shield firmware, could be some router configuration blocking certain port ranges.

Hard to tell as we haven’t seen this yet.

Have you tried it with Blynk by itself? You could try the Blynk forums as I referenced above and see if anyone has additional information.

Cheers,

Craig

#42

Check this post here, worth a shot Connecting Issue with Arduino uno and Cayenne Via Ethernet Shield W5100

Also check that your ethernet cable is not bad or a crossover cable, and that there is no SD card plugged in.

Other than that I’m at a loss as well. Does it show a link light when plugged in?

#43

I will try it with blynk.

#44

He gets an IP, so it’s a port blocking kind of thing, or a driver incompatibility, or nutty hardware.

Cheers,

Craig

#45

Yes but I have Not a Ethernet shield I have got a wifi shield . The LEDs on the shield are blinking. And I got an IP adress. The only Problem is the connection to the mydevice server

#46

Do you have an ethernet shield you can try to rule out the wifi shield?

#47

No only wifi shield

#48

See this [SOLVED] Unable to connect arduino.mydevices.com:8442