Unable to reach arduino.mydevices.com:8442 - putty advice

I’ve including and following the instructions in order to connect my arduino to cayenne cloud service. After setting up as the instructions I only get the error :

[0] MAC: FE-EF-DD-D4-A5-AE
[0] Getting IP…
[1524] My IP:
[5001] Connecting to arduino.mydevices.com:8442
[10316] Connecting to arduino.mydevices.com:8442

and so …

I’ve tried DHCP and Static IP with the same results. Any advice regarding this topic ?


Looks like I’ll have to type up a guide for troubleshooting arduino connection issues tonight. Until then you can try to do as much as you can from here Troubleshooting Pi Showing Up as Offline in Dashboard to see if you have any connection issues. If you have a pi and are willing to install Cayenne on it you should have the same connection issues with the Pi and can go down through that guide.

1 Like

Looks like a port blocking problem.

If you are on a work network, you might have problems as many corporate networks block these ports.

If you are at home, set that IP to the DMZ temporarily, and see if all is well.If it works, open up that port at least and try again.



Thanks for the response. Regarding the topic you are refering to, there is a test I can do :

elnet cloud.mydevices.com 8181
telnet: Unable to connect to remote host: Connection timed out

Currently the arduino library is pointing to arduino.mydevices.com:8442 . Is there any difference between cloud.mydevices.com:8181 and arduino.mydevices.com:8442?

I’ll be trying that configuration on my network to allow all the traffic. Thanks for the response.

8181 is the port for the Pi

Basically I can think that I can be pointing my arduino sketch to the Pi’s port ?

@bestes, any update on customizing or changing the default port numbers?

In my experience, typically the ports meant for encrypted traffic are open.

Might try the IRC over SSL ports 6679/6697 for example as who still uses IRC :stuck_out_tongue:


No, you will need to use the arduino port 8442

@o11, did popping this on the DMZ sort you out?



Im having problems with this aswell it keeps sending Connecting to arduino.mydevices.com:8442
to the serial monitor, Im also on a local network.

Check your router settings to allow outbound traffic on port 8442. Most routers will allow outbound traffic by default, but on corporate networks, or ultra paranoid folks like me may tweak the settings to disallow any traffic that isn’t explicitly defined.

As mentioned above, you can try putting your device IP in the DMZ temporarily and if it works, then figure out how to allow outbound on 8442.



Thanks for the answer but Im afraid putting the device ip in the DMZ didnt work either :S

[0] Using static IP
[1300] My IP:
[5001] state 0, tconn 0
[5001] Connecting to arduino.mydevices.com:8442
[6833] Connect failure
[10002] state 0, tconn 0
[10002] Connecting to arduino.mydevices.com:8442
[11837] Connect failure
[15003] state 0, tconn 0
[15003] Connecting to arduino.mydevices.com:8442
[16837] Connect failure
[20004] state 0, tconn 0
[20004] Connecting to arduino.mydevices.com:8442
[21839] Connect failure
[25005] Connecting to arduino.mydevices.com:8442
[26828] Connect failure
[26829] state 0, tconn 0
[30006] Connecting to arduino.mydevices.com:8442

This is what appears in the serial monitor with debug on

And now I changed IP and it worked for some seconds

And then back to the same

Well nevermind, Im gonna forget this site like all the other iot sites … It looks nice but it does nothing.

Hi @Volkun,

It’s likely a network configuration issue on your end, I’m sure we can get to the bottom of it. Presuming you have a computer of some sort on your network (and that computer can ping your Arduino), we can try to verify your connection to arduino.mydevices.com

If it is running OS X or Linux, you can run

telnet arduino.mydevices.com 8442

on your command line.

If things are working, it will disconnect you right away, but you’ll get a message like “Connected to arduino.mydevices.com” first.

If you’re running Windows, you can download PuTTY: Download PuTTY: latest release (0.77) to make the same test. You’d be looking for these settings:

Once you click ‘Open’ there, if you get a popup with ‘Connection closed by remote host’, then your computer is able to communicate with arduino.mydevices.com on port 8442. If you get a blank black window and no popup message, you’re blocked for some local reason that we can continue to help you figure out.

1 Like

I had same issue. I downloaded PuTTY and I got “Fatal error” message. Then I searched how to open certain ports on my router and because I am using WDS system, I had to add port 8442 to both of the devices (router and the bridge). That solved this problem.

Here is how you can add ports with TP-Link routers: http://www.tp-link.com/lk/faq-72.html

To check if your device is even on the device list, go to DHCP, DHCP Client List and search for ESP device.

Hope this would help somebody…

Sorry, for acting like a jerk, I guess you people find loads of people here. It seems like the port is blocked, I did exactly as you told, a blank black window pops for a second and disappears.

Also, today Ive tried to connect an arduino (mega) and I cant even seem to manually set an ip, it always prints
[0] Using static IP
[1300] My IP:
[5001] state 0, tconn 0
[5001] Connecting to arduino.mydevices.com:8442

And gets frozen here and doesnt do anything more.

Thanks in advance and sorry for being a jerk.

Have you tried to connect your computer to this server. Use telnet or putty.
If you have OSX or Linux try to type on terminal:
telnet arduino.mydevices.com 8442

I have done this, black screen pops for 1 second and disappears. The port is indeed blocked it seems :S

Have you a firewall in the system, in the router, or Antivirus, or program that block the in/out connections? Have you a direct access to the internet or behind server?