Adding new server



While adding new LoRa device, I coudent find the thingpark server we are using ""
Is there a way to add this server to the list of Actility servers?



Hi Omar,

There is no way to add it via the user-facing GUI, however we suspect that this might be a whitelabel which just redirects back to one of the Actility servers that are already listed. So a good first step to try would be going through the list of Actility servers that are already displayed, and seeing if any of them work for you. If that doesn’t do the trick then please let me know, and we’ll contact Actility about adding this server to our platform.


@eptak @croczey any input here?




None of the servers worked. I appreciate if you can contact actility to add this server to your platform.



Hello! I would also be interested in this. I would like to add KPN actility server to the platform.


Hi @marius.stanasel, welcome to the Cayenne Community. (and @osinno if you’re still out there this may be of some interest to you as well)

For a few months now, the UI for adding an Actility device has allowed you to enter a custom server, so you’re no longer limited to the list in our dropdown menu, just start typing in the field. I should note that what our server is looking for here is called your ThingPark DX Profile, which is generally your domain with -api appended, without the part.

So if the server you were looking for was, for example,, what you should enter in this field is simply example-api. Give it a try for your KPN server and let me know if you have any trouble.


Hi @rsiegel, thanks for the reply.

I’ve tried all combinations possible, without success. All i received was signal strength details, so i presume the data does not get decrypted.

Here is the adress i use for posting messages:

according to you, i should try, is that so?


This looks like a different issue? If you’re getting RSSI/SNR we’re probably connected OK and it might just be an issue with the encoding of the data or the decoding on our end. Can you send me via PM the DevEUI for this device? I can look in our logs for the payloads and see why they aren’t being decoded properly.


Hi again @marius.stanasel,

Thanks for your PM with the DevEUI information. After looking on our end, we’re seeing payloads that don’t make sense, to the point where we’re suspecting the issue is not our decoding, but possibly encryption on the Actility side. The fact we’re getting even that means that the ThingPark Server field is entered correctly however, so that’s not the issue.

Can you verify that the Application Key and Application EUI information you’ve entered on the physical device itself match those entered in the Actility network server portal? If these are mismatched it could cause us to receive payloads like this that look encrypted and we’re not able to parse on our end.


Hi rsiegel,

Keys match, I’ve checked them. I have to say that if an changing the Server address to anything, I still receive those SNR values…



It could be that I’m misunderstanding the purpose of that field and it might be set wrong. Let’s revisit it. What do you have in that field currently?

If you ask Actility for your ThingPark DX Profile, this is what should be in there. Like I’d mentioned before it is generally suffixed with -api. Most of the other users I’ve encountered with this had a format of something like

so they would have a Thingpark DX Profile of



I’ve not seen a server format like the one you mentioned above where it is not a * format so I’m not sure if this holds true in your case and it may be best to ask Actility itself what the proper Thingpark DX profile is.