Arduino pin can't be changed in any new Widget

I’ve just connected an MRK1000 Arduino board to Cayenne. This board isn’t in the list of Arduino boards so I just added it as Arduino Uno device + WiFi 101 Shield. It worked properly and I can see the board in Cayenne Dashboard.

The problem is that when I try to add a Widget like a generic Digital Input or generic Digital Output I can’t change the “Pin” field so I can’t add it to the project, The Connectivity box can be changed to “Digital” but in any case the “Pin” box seems empty, I can’t select anything so I’m not allowed to add the actuator or the sensor. I think I have the same problem with all the Widgets. Please do you know what I’m doing wrong?

Thanks a lot

@acorral welcome to cayenne community.
this problem is kind of new here. so can you post a screenshot of the dashboard where you can not add the pin.

Hi @shramik_salgaonkar, it seems that the issue can be solved including the CayenneMKR1000.h file library (that I found surfing on the internet) instead of the CayenneWiFi101.h one.

Thanks in any case.

1 Like