Bug Filed on 12-24-2015: BMP180 Sensor not added: Failure


I’m getting the following error when trying to add the BMP180 sensor to my dashboard:

Please fix the following errors:
Failed to add the sensor, please re-check your settings. Make sure you selected the correct Channel/Slave Address.

I followed everything here: https://learn.adafruit.com/using-the-bmp085-with-raspberry-pi/overview


Hey Adam,

We’ve added several BMP180’s since our most recent update, so I’m sure BMP180 is working. And, you can follow this tutorial here (I think you’ve seen it already?) https://tbohwalli-features.mydevices.com/cayenne/tutorial/bmp180.

Did you reboot the Pi after initially downloading the agent?


Also noticed that linked tutorial has the Pi Cobbler setup upside down… not sure if that might have affected the wiring.


I did not use that tutorial but the one I used is pretty much identical. I don’t have the Cobbler adapter so I am just using the breadboard connected right to the Pi pins. I think maybe one of the issues with this sensor is that there is no place to enter the address?


Hmmm. never experienced issues with entering an actual slave address for BMP180…

@eptak is there a situation where the slave address needs to be entered for BMP180?


Ok, just tried this again, and it worked now too? So weird…


That is weird. We’ll be on the lookout if we can reproduce this too. Not sure as to a reason, maybe a really slow communication between WebIOPi / the agent / cloud server.


BMP180 has fixed slave address WebIOPi is aware of, so don’t need to specify that in the UI.