Bug Filed on 03-09-2016: Increase memory


I let mine run overnight, looks like mine is increasing too.


Processor at a healthy level though?


Yep, I never had any issues with the CPU usage. At least not that I know of.


Every 8 - 10 hours:

[49095.771760] Out of memory: Kill process 311 (python3) score 543 or sacrifice child
[49095.783214] Killed process 311 (python3) total-vm:743120kB, anon-rss:556724kB, file-rss:0kB

Now hangs. Its not usable!





We’re working on this. We have two higher priority fixes we are working on through the weekend. We will release a hot fix for this issue as soon as we are able to focus efforts here. I can send out an update on this thread early next week.

In mean time, temporary fix was put in this post:

Sorry about this,



When new version?


Releasing fixes for critical Pi offline issues on Monday. This is next priority and we hope to hot-fix a release next week.


From My Pi B+
This pattern repeats every day at present

Will post again in morning comparison if it ‘makes it though the night’
~ Andrew


Appreciate the screenshots here @picaxe! Helps Cayenne team troubleshoot and reproduce.



Agree you can’t beat a good graphic and some good old prt scr button, crtl C, ctrl V…

Looks like I need to set up a trigger > Max Mem = Rebbot ?
Both my Pi are crashing after 18hours at the moment so can’t be left unatended
~ Andrew


Same here… every 12 hours in my case.
I disabled cayenne until next version because I can’t be left unatended.


Hey Cramos,

We will be working on this now. Keep you updated.



Workaround for now…
I am re-booting every 12 hrs using scheduler.
~ Andrew


@cramos @picaxe @ats1080s Hey guys, we released a fix for this. Let us know if the issue still persists. Thanks for hanging in there!



Hi there. I am having the same problem, ram increasing gradually through the day, resets after a reboot. Processor and storage not affected. See pic below,


So the section that Cayenne can control is the ‘Processes’ section. Cayenne agent makes sure this percentage stays at a manageable level. The Pi itself handles the I/O Cached percentage. Rebooting the Pi will reset the I/O Cached. From what I understand, we really don’t have much control over it. Does that make sense?



Figured it out: it’s a wheezy v. jessie thing for type rpi B. Wheezy (tried version 2014-12-24) seems to manage RAM much better than Jessie (version 2016-03-18). On startup: wheezy 24% v. jessie 45% ram usage. After half hour use, ram is still at 30% while on jessie it rises above 55%. Sticking with wheezy for type B then.


I have 4 Pi set up with the RAM from each plotted into one ‘project’ so will do a fresh start and boot next week and post a few days of RAM Plots up… Watch these spaces…
~ Andrew


This would be great. Would be helpful to show the Processes, File Buffers, I/O Cached comparison as well.