Bug Filed on 03-09-2016: Increase memory


#21

Hi there. I am having the same problem, ram increasing gradually through the day, resets after a reboot. Processor and storage not affected. See pic below,


#22

So the section that Cayenne can control is the ‘Processes’ section. Cayenne agent makes sure this percentage stays at a manageable level. The Pi itself handles the I/O Cached percentage. Rebooting the Pi will reset the I/O Cached. From what I understand, we really don’t have much control over it. Does that make sense?

-B


#23

Figured it out: it’s a wheezy v. jessie thing for type rpi B. Wheezy (tried version 2014-12-24) seems to manage RAM much better than Jessie (version 2016-03-18). On startup: wheezy 24% v. jessie 45% ram usage. After half hour use, ram is still at 30% while on jessie it rises above 55%. Sticking with wheezy for type B then.


#24

I have 4 Pi set up with the RAM from each plotted into one ‘project’ so will do a fresh start and boot next week and post a few days of RAM Plots up… Watch these spaces…
~ Andrew


#25

This would be great. Would be helpful to show the Processes, File Buffers, I/O Cached comparison as well.

-B


#26

We recently stopped officially supporting Wheezy, since Raspberry Pi stopping doing new releases. There may be bugs that appear as we iterate new releases of Cayenne. We are no longer regression testing on Wheezy with new releases…just a heads up!

-B


#27

Makes sense.
I will do some housekeeping and throw the switch on Wheezy over to Jessie Lite ?
Let you know how we get on.
~ Andrew


#28

Andrew, Jessie Lite isn’t directly supported either. I believe there is a work-around on here somewhere…

Ian


#29

Thanks for the heads up…
I am looking for a recommended run list for say starting from a formatted for stepping students though all the needed skills and ‘why-for’ at the same time about building up a system from scratch… I have yet to have a good look but just wondering how much of the following (if Any) is needed that I normally run on courses for the shortest run home from say a freshly flashed Full Jessie ?

  • sudo raspi-config (expand card and any local settings needed ?)
  • sudo apt-get-update
  • sudo apt-get-upgrade
  • Install Cayenne from ssh etc
    I can quite understand that Nothing has to be done but just checking this out thanks.
    ~ Andrew

#30

Andrew,
You might take a look at this thread from a couple months ago-
http://community.mydevices.com/t/install-walkthrough/226?source_topic_id=291

Sadly some of the info in there is somewhat dated, for example as of last Tuesday the most current version of Raspian automatically expands the file system, pretty much before it does anything else upon initial boot up.

I think we both have the same vision.

Let me know if I can help, just don’t make it too immediate, time is not on my side.

Ian


#31

Me too!

I rebooted all at 09:00 and they have run for 12 hours now-


The top left is a RPi 3b on WiFi
Lower left is a RPi 2b on CAT5
Upper Right is a Zero on WiFi
Lower Right is a Zero on CAT5

-Ian


#32

Just an update and FYI anyone who might be interested:

  • Clean Jessie FULL install
  • First boot, no devices added (yet)

    and

    and

    and

    Will repeat this in a few hours / days for general information / record
    ~ Andrew

#33

FYI and just a general test and update:

Here is a Pi B+ with Jessie Full and clean install as above and no other configurations after one week.

I will cycle though the 4 types of Pi I have here on test and see how they compare.

~ Andrew


#34

Thanks for posting this. We actually only have control over the ‘Processes’ number. This number should stay around 25% - 33% I think. Rebooting enables the Pi to clear the I/O Cached… hmmm, Do you know of command to manually clear the I/O Cached on the Pi, where a reboot wouldn’t be required?

-B


#35

IDK of a command, but that would be fantastic. As of now, I have the Pi scheduled to reboot every day. However, this messes with my servo that I have added, and I sometimes have to re-add it…


#36

@picaxe @trentwainwright Can you try the following? See if it lowers the Pi I/O Cache…

sync

sudo sh -c "echo 3 > /proc/sys/vm/drop_caches"


#37

That seems to do the trick. It dropped the memory from 72% to 48%! Thanks man!


#38

Now I wonder if we can’t get the Cayenne agent to run this once daily. Maybe put this option as a settings configuration that user would be able to turn on / off. Anyway, thanks for confirming the command.

See you around!

-B


#39

Works great for me too. RAM dropped from 95% to 38% !