Can't access via Remote Desktop

I hope someone can help me out here. I have a Raspberry Pi Zero v2 running Jessie (full not lite) installed around 2 weeks ago. After logging into cayenne my devices I can see the pi and the stats for RAM, CPU etc, but the remote desktop refuses to connect whether on the same local network or not. I have attempted to connect on 3 separate devices and tried both Chrome and IE now all with the same result - “desktop connection time out blah blah blah, try again later”.

Can someone shed some light on this here, any help would be gratefully accepted.



And welcome to the Cayenne community!

Did you enable pop-ups for the remote desktop?


Yes, I saw the FAQ’s on that issue but I have enabled pop ups. I suspect the issue may be that I also have motion running constantly streaming live from a web cam, and it may be preventing any remote session to start on the pi.

Can you confirm that this would prevent the remote access feature in the cayenne dashboard accessing my network connected pi zero?

I’m not entirely sure if that would prevent the remote desktop feature from working, but my thinking is that this could be the issue. Only way to be sure is if you’re able to use clean install of Cayenne on an SD card and try again to compare.

Did you already have tightVNC installed on the Pi prior to installing Cayenne? We’ve seen issues occur with this as well.



This was a brand new formatted sd card when I installed Raspbian Jessie (full version) onto it. Then I installed MotionEye to capture live footage from the attached Rpi camera module.
Next I installed Cayenne via the wget link and then the bash command over SSH from a networked PC.

Using MotionEye I can see a live stream in a browser via the Rpi Zero’s assigned IP address, and Cayenne can see the Pi on my network when I use a PC or via the Cayenne Mobile app. All the stat gauges on the dashboard show data, but the only issue is with accessing via the Remote Desktop feature, which just hangs and then times out.

I re-installed Cayenne today after a router reboot and re-assigned IP address, the results are exactly as above.

Any further ideas?


So have you tried running remote access without MotionEye already being on the Pi?


At this moment in time no, I wanted to check with your support team if
anyone else had this same issue with MotionEye installed whilst attempting
remote access via Cayenne mydevices. I can try this though even if only to
eliminate it as an option.

Ah I see. I’ve not seen this come up before, so I’m not sure. If remote access works one of your Pi’s without MotionEye installed then I would assume MotionEye is the issue. Keep us updated!