Bug Filed on 04-26-2016: App slow to start

I set everything up yesterday and everything worked well.
I came back to it this morning but found the Android app very slow to start.
Initially it went to a completely white screen. Android told me the app wasn’t responding and asked did I want to close it or wait. I closed it and started again.
This time after a long minute or two the white screen went to a black screen with the Android status bar at the top. Again after a wait Android reported the app not responding. I opted to wait and soon it started.

It seems to me that the app wants to search and find a device before it brings up the opening window. Would it be better to start the app to a start window then press a button to search for connected devices?

I had shut-down the Pi last night and powered it up before trying to connect to it. It had fully booted before I tried to connect.

Once the app had opened, it showed my device I set up yesterday (that I had given a name) but said it couldn’t connect. It had found another device at the same IP address but said I needed to set it up (reload cayenne again) which I did. Why would it not recognise the device that was setup yesterday?

I went out and while I was away from my LAN I thought I would try to look at my Pi. It all worked well.

When I was back home I tried looking at it again and I got the white screen then black screen and eventually the app started.

Are these symptoms other people are experiencing with the Android App?
Is there something I should be doing differently?

Thank you

I have the same problem.

Hi. Iam having same problem and app on android keeps crashing.

@gregwarner52630 @tad.dvor @rick1 hey guys, we’re looking into this. Thanks for letting us know! May need to ask some follow up questions after we investigate, I’ll let you know. Keep you updated on this.


Hi guys, problem solved after samsung update to 5.1.1 everything working well so far. I can now have some fun.

1 Like