Bug Filed on 05-03-2016: Startup questions

I have a few questions. The system doesn’t seem to be responding properly but I might be doing something wrong?

I have deleted the beta version from my Android Samsung S5 phone and installed version 1.0.0 from the app store.
I deleted my Pi2B and got it to reinstall. All seemed ok and I got notified Pi setup and ready to use.

The newly setup Pi is running.
Start the Android app
get a white screen, (advised not responding twice but I told it to continue to wait)
after about 70 seconds I see the device name and IP address
(On another start of the app the white screen changed to a black screen with the android task bar at the top waiting.

When I go to the device dashboard I get a message at the bottom saying device disconnected.
I thought this was making the connection, how do I make a proper connection?
Once I bring up the device dashboard I see CPU, RAM, Storage, RPI (temperature in Fahrenheit), Network speed - 0, Processes - Loading, Commands.
How to change the RPI temperature display to Centigrade?
Why is the network speed always 0?
Why does Processes only ever say loading?
If I try to send a reboot command it says command not sent.

On a Windows 10 computer using Chrome Browser.
If I log into Cayenne I see my device, but
On the dashboard I only see: CPU, RAM, Storage and Commands.
Why not Network speed, Processes, and RPI temperature?
If I try to “Connect” it ends up saying “Connected” but how do I see its desktop?
Why do the gauge tiles default to 33 to 66%?
Why don’t they seem to change scale if I try to update them?
Is there any way to set when they change from green to orange?

I don’t see any use moving on to connecting a sensor till I can see a reliable connection to the device and these basic system parameters?
Any thoughts please?

Thank you

Some followup.

I found that my PC web browser was blocking the remote desktop from opening a new tab.
I told it not to block any from this domain.

Now It says it is asking the user of the device for permission to make the remote connection.
Do you need to have a screen, mouse and keyboard connected to the RPi to be able to allow remote access?
Why can it get this close to making a remote connection but not update its basic system parameters or allow remote reboot or shutdown?

My Samsung S5 phone is running Android V 4.4.2.

I have tried running Cayenne and a Samsung T4 10" tablet Running Android 5.0.2
There was a warning that the app was not for tablets but it opens without a problem.
It finds my device but says it is disconnected.
I have tried rebooting and waiting plenty of time.

Thank you


Rick, great questions. Many of these are in discussion already, but its good to remind our friends at Cayenne, @bestes , that there are still some places that need improvement.




There are several open bug reports on this-

In addition, although I don’t usually use ‘remote’ I checked on the 4 RPi’s that I currently have running and remote only worked on 2; A Zero that is wired into the network and a 3b that is on WiFi. The ones that didn’t work were a 2b that is wired and a Zero that is WiFi. There has been discussion that VNCserver and/or tightVNC may be the culprit.

In the Android beta releases this field was °C only, I think it was 1.0.0 where it went to °F only. I would expect this field to change to user select-able in an upcoming release.



1 Like