Cannot Access RPi with Remote Desktop Feature

I saw the response in the FAQ:

"The Remote Desktop feature is not working.

You may need to allow popups for the remote access to work."

I’m using Cayenne on a tablet, and I’m getting the message, something to the effect of “tell the remote user to press Share This Computer”. However, I don’t see anything on my Raspberry Pi desktop that would indicate the it’s being accessed remotely. Nothing changes on the desktop.

When you say “allow popups” are you talking about settings in Chromium? My web browser for my RPi. I don’t think the GUI has a setting like this.


I also have problem with Remote Desktop Connection Feature.

It’s nothing related to popups, the PIXEL update for Raspbian broke our Remote Access feature and we haven’t had a chance to fix it just yet. When we do, I’ll be sure to make an announcement on the forum and will likely bump these threads as well.

Until then, if you want graphical desktop remote access to your Pi, follow this guide on the official Raspberry Pi website to use the built-in VNC connection: Raspberry Pi Documentation - Remote Access

If you just need shell access to the pi, good old SSH is your best bet.

I dont know if this exactly your issue, but i also had Problems connecting to my Rpi3 with RD.(win 10)
I found this Post wich solved the Problem for me.

Link: raspbian - error - problem connecting to Raspberry Pi 3 with xrdp - Raspberry Pi Stack Exchange

Doing just sudo apt-get install vnc4server, followed by either a reboot or a sudo service xrdp restart fixed it for me,

I had this issue, enabled popups in chrome and that alone solved my problem. So it was browser popup issue for me. Thanks to all

1 Like

Hey @shaunmcmaster66, welcome to the Cayenne community and thanks for joining to let us know.

To update since this was an older thread, we did put a fix in place for the original issues I’d mentioned in my first post on this thread, I just never found it to update here. So I’m going to go ahead and move this one to resolved. If anyone reading is still having RDC trouble feel free to make a new thread we can troubleshoot it.

Mine is working fine from a long time ago :wink: