Bug Filed on 05-02-2016: Disconnected from remote device



What dashboard are you using? (Web, iOS, Android)


What OS? (Jessie, Wheezy)


What Model Pi?


Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!

Have installed on pi, everything went well. Pi is connected via ethernet. Trying to connect using my android smartphone (S3 running jellybean) and I immediately get the “Disconnected from remote device”.

Weirdest thing is the dashboards register values for CPU, RAM, Storage and Temperature, they are not 0. Also, once I tap on one of them, I can get a full timeline graph going back about an hour ago.

Have reset both pi and S3 multiple times, same outcome.

Any ideas?


Bug Filed on 05-03-2016: Startup questions

Hey Nikos,

Hmmm, not sure what the issue is off top of my head. We’re working on a few other Android bugs, but should get to this one soon.

Keep you updated. May reach out again for more information.



I am also having the same problem. Seems to be related to the actual Android version running on the phone. Although Cayenne is not recommended for tablets yet, it seems to run best on one of our Nexus 7 tablet running Lollipop 5.1. Runs almost flawlessly. Strangely we get the “disconnected from remote device” on our Huwawei P8, running Android Lollipop 5.0. We can control the pins, but everything else is static e.g the temperature, ram, etc never changes but the graphs are accessible. We have had varying results with other different phone models we’ve tried.


Again strangely the “disconnected from remote device” error only seemed to prop up once I updated from the beta version to the Google play version. Never had the problem on the beta version.


Good idea scorpio. I will uninstall and reinstall the beta version and see how it reacts.



Please let us know what you find!

@scorpionfootwear @nchlo You only ever did a single install from the Android device, right? I ask because I wonder if when you deleted the Beta app and download from Play Store, maybe you installed an additional instance of Cayenne on the same Pi.

Thanks for your help here ,



I have tried many installation attempts because it never really worked right for me. During these (but not on all instances), I have taken the extra step of erasing the sd card and reinstalling jessy from scratch so as to ensure that cayenne deals with a clean pi.

I will try this last approach once more so that there is a fresh pi and a new cayenne installation and report back with my findings.



I also have same problem, as soon as the device is launched on android app, got message “disconnected from remote device”. Strange thing , I could see all the CPU, RAM parameters and access the GPIO dashboard and switch the light on/off on channel 18.

created the widget for Light - it shows “server error”

The whole thing works nicely on web dash board.



I did completely erased the sd, reinstalled jessie and did a fresh cayenne installation. The android version still shows “disconnected from remote device”, while the web dashboard registers all the pi data as it should.

Few observations/questions:

  1. While I had removed the device from the web dashboard AND erased the sd prior to this installation, there is currently data for my pi going back 2 days visible on the web dashboard. Should that be the case? And how is it possible?
  2. The android cayenne app seems to launch fine when it’s done within the same network that hosts the pi (home wifi) but is less reliable, sometimes completely crashing (cayenne isn’t responding) when I am trying to access from my work wifi.
  3. Internal Pi temperature is measured in F on the android dash - can I change that to C? And why is it not available as a web dash?
  4. Finally, during the initial setup, pi discovery is feasible only if my android is connected to the same router as the pi. However, there are environments with multi-router/bridges/extensions - there pi discovery is impossible, even though there is a central router taking care of DHCP etc. Is this something that’s technically difficult or the result of an implicit assumption that android and pi have to be directly connected to the same router?

Sorry for the lengthy update.



@nchlo @scorpionfootwear @mahi Hi all, we just released an update to the Android app. Can you see if the issue you experienced is resolved?

We released specific fixes for the ‘server error’ issue. I’m thinking the ‘disconnected from remote device’ may also be resolved in the process.



Thanks for the questions!

  1. That’s a good question. I’m not entirely sure, I’d need to reproduce the scenario on my end and figure it out. I think there may be a ghost remainder of WebIOPi files leftover from removing device. We’ll fix this. But if you said that you wiped the SD card then this doesn’t really make sense.

  2. This may be due to port issues. We’ve seen numerous connection issues while on corporate environments. Port 8181 has to be open for Cayenne to connect.

  3. Not being able to change to deg C is a bug we will fix. Not being availalble in web dash was an oversight on our part. It will definitely be available.

  4. I would say it’s technically difficult. We actually just implemented fix for Android where you can manually search the network from the Android phone to search for the Pi. So, the idea is if you can SSH to the Pi from your phone, you should be able to push the Cayenne install by manually entering the IP Address.

Thanks for the questions!



@nchlo @scorpionfootwear @mahi still having issues here?


Hi there. switched to a different phone with no issues. I will go back, reactivate the s3, update the app and get back to you.


Sure thing, sounds good!



We’ve releases several updates to Android app that hopefully fixed this issue. Moving this to Resolved. Go ahead and open up another topic if you come across anything :slight_smile:



Hey there, i am still facing all these above mentioned issues,
for now can you tell me the way to open port 8181.?


@karanbhatia015 we have new agent 2.0 so we have the bugs fixed.can you try installing from the web dashboard and pi terminal window.


Do you want me to run the code again.?


try with a fresh install of raspbian stretch https://www.raspberrypi.org/downloads/raspbian/ and then install the cayenne.