Help connecting to Devices


Hello, I’ve registered 2 Pi’s. The dashboard presents the default widgets for each Pi but shows no activity, if I send a command I get a “Device Off line message”

Not sure what to do next as the Pi’s have registered but cant seem to connect to them. Ive tried reinstalling the Cayenne software but that doesn’t help.

Any ideas greatly appreciated!


after the Pis get loaded with Cayenne,
they need to do a reboot.
A reboot may take 4 or 5 minutes on a Pi3,
particularly if you have slow memory.
-after you let it sit a while, (10 minutes)
-can you do a refresh to your dashboard?
I’ll work with you here…

I have several Cayenne devices online.
I’m thinking of making an endless loop cycle on 1 of the devices,
just to ensure Cayenne connectivity.
-you never know when the server may go down.


Many thanks Bill appreciated!

Seem to be making progress. By being a bit more patient and waiting at least 5 minutes I have got the live data on the basic widgets but still get the off line message is I send a command - strange.

Will reboot everything, leave it a good half hour and see what happens!



If you’re still having problems run down this post and see if anything stands out as a problem Troubleshooting Pi Showing Up as Offline in Dashboard


Thanks Adam. Went through the full list, found that there was no id in the .ini file.

Now have live feed from the standard widgets and can reboot etc. When I click “bring your own thing” to try the DHT11 sensor project then I just get the spinning wait icon and nothing happens - do you what the response should be after clicking this?

Many thanks


Also, still get device “off line” message if trying to connect via App but can connect from laptop desktop


Check that you are signed in to the same account with the app, some other users were signed in with the default phone email account and not the email that they signed up with. Also, MQTT is not available in the app yet, so that would be another reason you don’t see your device.

This means that the Cayenne server did not get any connection with the credentials supplied. When your board connects the spinning circle should go away. Can you post the code you are using?


Sorry for the dumb questions (working a bit beyond my skill level - but learning!) - which code would be useful to see, can you give me a pointer and I will copy the relevant code - many thanks again!


Which credentials should be used on the script running on the pi? - I presume that username and password isn’t the same as the login for Cayenne, perhaps that is what Im doing wrong - also is the Client ID the name given to the Pi in Cayenne?




good question


Any code you currently have. I saw you were trying to use the MQTT API (bring your own thing) so I assumed you had some code there.

The username, password, and client ID are all presented to you when you create the MQTT device (click the bring your own thing button) Your Cayenne username/password will not work here.