Bug Filed on 05-27-2016: Disconnected from the remote device

What dashboard are you using? (Web, iOS, Android)

Web, Android (Samsung Galaxy Alpha)

What OS? (Jessie, Wheezy)

Jessie Full

What Model Pi?

RASPBERRY PI 1 MODEL A+ and Raspberry Pi 2 Model B

Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!


I have two phones Samsung Galaxy Alpha. When I like to select one of the two raspberries and go to dashboard I receive red error at the bottom of the screen “Disconnected from the remote device”. I try with WiFi and 4G connection, I also try with factory reset on my mobile phones but again I have the same error. If I wait for about 60 seconds on the dashboard and I try to switch some of the relays they start to work. From all other mobile phones (Android and iPhone), from Web (Google Chrome) everything is OK. Can you tell me what is the problem. My username is prontoo@gmail.com maybe some of the administrators can check on the server for some errors for my username.

Best regards,
Ivo Markov

Is your Pi on wifi or a connection with unstable WAN?

Download pingplotter https://www.pingplotter.com/ and trace the IP of Cayenne’s cloud server (nslookup cloud.mydevices.com - for me) on a computer from the same network the Pi is on. You will get packet loss on the last host since it doesn’t respond to pings but that will give you a rough idea of where/if there is a network problem.

I will try later with pingplotter. But I also try to connect my raspberry with LAN, with WIFI, and also I try to connect my raspberry throw wifi hotspot from my tablet, and I try with 3 other internet providers on different places but again the same. As I write before the problem is only with all Samsung Galaxy Alpha phones, with galaxy Note 5, Galaxy S5 and some other is OK. So the problem is connection from Samsung Galaxy Alpha phones to your Cloud services.

Best regards,
Ivo Markov

What version of Android are they running?

Android 5.0.2

May be the problem is Android 5.0.2 and 4.4.4. Because with all other versions work OK.

@prontoo (and anyone else reading who may have seen this issue):

I’m happy to announce that we’ve just released the 1.0.3 Android app to the Play Store, with improvements specific to this issue. When you have a moment, please update the app on your Android device by visiting the Play Store app > My apps > Update

We’d love to get your feedback as to whether this successfully resolved the issue, and if you have any other trouble or comments.

rsiegel Tnx for the upgrade 1.0.3.

I install the new version 1.0.3 for Android but my problem steel persist. Again I have red message at the bottom on my android dashboard “Disconnected from the remote device”. As I describe, I have to raspberries on two different location and the problem is the same with both of them. If I leave my android application, even in background, for more then 60 seconds everything start to work fine with my two raspberries. If my android phone is on the same WiFi network with one of the raspberries again I receive the same error but everything work fine immediately, all my relays switch very fast without any delay.


Reading your issue more closely I may have confused it with a different connectivity issue that we addressed in this latest update. If that is the case, my apologies. Either way, it’s still not working for you on these devices.

Can you confirm that for all of your other devices (Especially the other Android device you mentioned that worked) were on the same WiFi network as the two Galaxy Alpha phones which give this error? What was the model / OS version of the Android device that does not have this error on the same network?

I suspect if the Galaxy Alpha phones consistently always fail on your network, but the other phones consistently always work OK, then it is probably not an issue with the network itself as ats1080 suspected.

I will investigate to see if we have a Galaxy Alpha device in the office that we can run a sanity test on.

Thank you rsiegel

I have made little investigation :slight_smile: and I realize that the problem is for all devices with Android version below 5.11. So all devices with 5.11 and newer work OK.

Best regards,

1 Like

Thank you for letting us know! This really helps narrow down the scope of the issue.