Bug Filed on 05-27-2016: Problems with install RPi3 [solved: corporate network issue

What dashboard are you using? (Web, iOS, Android)

web, android

What OS? (Jessie, Wheezy)

Jessie (with x windows, so full not lite I think?)

What Model Pi?


Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!

Install completes, pi reboots, but both the android app and the web are stuck on waiting for reboot. I initially tried the install remotely from the android app, then when that got stuck I killed the app, then installed manually with the wget’ed script. The manual installation completed and rebooted as well, but nothing showing up. Any clues?

Check everything networking related:

If everything looks ok there check the services:

  • sudo service myDevices status
  • sudo service webiopi status

Post back if everything looks good but still not showing online.


It’s a firewall issue - I’m in a corporate environment. I don’t think port 8181 is opened for external connection here. When I connect to a phone hotspot, it works, even though there’s a ‘conversation failed’ message from the myDevices service;

pi@raspberrypi:~ $ sudo service myDevices status
● myDevices.service - myDevices service
   Loaded: loaded (/etc/systemd/system/myDevices.service; enabled)
   Active: active (running) since Mon 2016-05-30 11:43:02 AEST; 1min 56s ago
 Main PID: 679 (python3)
   CGroup: /system.slice/myDevices.service
           ‣ 679 /usr/bin/python3 -m myDevices -P /var/run/myDevices.pid

May 30 11:43:02 raspberrypi systemd[1]: Started myDevices service.
May 30 11:43:02 raspberrypi systemd[679]: pam_exec(login:session): conversation failed
May 30 11:43:02 raspberrypi systemd[679]: pam_unix(login:session): session opened for user root by (uid=0)
pi@raspberrypi:~ $ sudo service webiopi status
● webiopi.service - LSB: WebIOPi initscript
   Loaded: loaded (/etc/init.d/webiopi)
   Active: active (running) since Mon 2016-05-30 11:43:00 AEST; 2min 3s ago
  Process: 559 ExecStart=/etc/init.d/webiopi start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/webiopi.service
           └─574 /usr/bin/python3 -m webiopi -l /var/log/webiopi -c /etc/webiopi/config

May 30 11:43:00 raspberrypi systemd[1]: Started LSB: WebIOPi initscript.

It would be really good to use this service internally within the firewalled network, there’s no port restriction between computers within our network.


@murray.cox Totally. We’re going to look into it. Especially since we’ve seen that many businesses are using Cayenne.