Can't remove Digital Output from dashboard

Hi guys,
Do you have any workaround for the situation when you remove an output from the dashboard and it keeps in the removing status forevere?
I’m using an Arduino Uno with a ESP01. As you can see in the print below the Digital Output stays Removing…

What about log off and then log on. Also refreshing the browser might help? :slight_smile:

Hi @ognqn.chikov,

I done that thousands of times and also tried to remove it a lot of times.
The workaround I found was instead of using the dashboard in the browser, I deleted the output in the Android App and worked fine.

1 Like

Okey, nice workaround! Thank you for posting it :slight_smile: I hope this is not a bug :slight_smile:

@joaoduarte_89, if you ever get a widget stuck in this ‘Removing’ state, a dashboard reset should remove it as well. This can be done from the upper right cog icon on the web dashboard > Reset Dashboard.

Hi @rsiegel,
Just tried now to remove all my widgets and they are all stuck in “Removing” state as you can see bellow.

After that I tried to reset the Dashboard and they all appear again, but none of them work :blush:

I will try to remove and add again my Arduino to Cayenne to check if the problem solves by itself. I’ll update this post once I arrive home since now I’m at work :smile:

Thanks for the detail. After the reset you should check that they are not missing any setting which would cause them to not work. For example I can see your switches have lost their icons, which is more of a superficial thing – but good to double check that any functional settings haven’t been lost.

My icons was also disappeared but after log out / log in everything comes to the place :slight_smile:

Hello again guys,
Yesterday I removed my arduino and added again and everything started working again. However I’m facing issue with schedules. They are not running at all…
There is this topic regarding this. Also today I’m getting http 503 while trying to access my dashboard. Is Cayenne under maintenance?

I was also getting HTTP 503. I restart my Internet Connection and it works. I think there is some problem with the Dashboard, because a couple of times this problem occurs! I reset the internet connection and it runs again.

Can’t do that since I’m at work :slight_smile: But I also found another workaround. I entered InPrivate Browsing and started working again… Maybe it is a cache problem.

Also try to reload the browser with the buttons: “Ctrl” + “R” :slight_smile:

Let me know if the 503 continues to be seen, especially with a browser refresh/cache clearing. We had a few other reports of it overnight and are investigating now.

As far as the Arduino Scheduler, we’ve had so many one-off bugs with it that we decided to re-write it, and are hoping to have something new to test in May. @joaoduarte_89, and you too @ognqn.chikov, would either of you be interested in being part of a private beta test of this new scheduler when it is available on a development server? If anyone else reading would like to be part of this too, please send me a PM.

Hi @rsiegel

The 503 error has gone for me. Everything is working fine now.
Regarding that beta testing for the new Arduino Scheduler I will send you a PM.

1 Like

503 Error is gone for me as well :slight_smile: