Dashboard remote problems

Thank you for taking the time to submit your bug/issue! Please use the points below as a guide when submitting.

  • Device & model Pi 2 Model B

  • What dashboard are you using? (Web)

  • Please describe the bug / issue as detailed as possible. Attaching the code and any relevant screenshots would be very helpful!
    I installed cayenne to Pi2 Model B and can login to dashboard on same network as raspberry pi and see the RAM CPU DISK update etc BUT when I login to the dashboard at work the RAM CPU DISK do not update and remain zero. Tried two different machines and browsers always the same. Raspbian Jessie lite installed on pi.

Hi @rossian, welcome to the Cayenne Community!

My initial thought here is that this is not actually the network that you’re viewing the Cayenne dashboard from, since the way our Pi software works is to send data back to our cloud server which can then be viewed from anywhere with an internet connection. So even when you’re on your local/home network, when you view your dashboard at cayenne.mydevices.com, the data is still going Pi → Internet → Cayenne Cloud Server → Browser.

I’m thinking perhaps something has locked up on the Pi or with our agent software itself, or with your home internet connection. Do you have access to your home network where the Pi is installed now? I’m curious if it is still showing as Online and with updating CPU/RAM/etc values from that side. If not, it may be worth just giving the Pi a reboot to see if that kicks things back into gear. Our Pi agent software should start automatically on reboot.

Thank you for the reply. I agree that if the raspberry pi is updating the cayenne cloud server then there is no reason why I cannot view the information anywhere. I am currently logged in at work and the dashboard still does not update CPU etc zero. The raspberry pi is online (i.e no offline message). I tried rebooting the pi and this as not made any difference. At home the dashboard works fine. Any ideas ?

At your work - are you sure that you do not use some kind of blocking software? Add block (there is no sense to block widget but who knows…) ?
Also what kind of browser and versions do you use ?
What about to download IOS/Android App and try to see if in your office is the same issue?

My work’s proxy blocks certain things on the dashboard such as the RPI’s stats also. all at zero.
I use my tablet and wifi or phone in i need to look at it.

It seems that work is blocking the webpage from talking to the cloud to retrieve the values for CPU etc. I noticed this using Chrome developer which shows network connection errors, could be due to port 5002. Pity this is the case but never mind.

Ah good find, we do indeed use the 500x ports for websockets for our cloud server, I hadn’t considered that. Here is hoping your employer would be willing to make an exception for this project.

It is major problem in Enterprise networks to block ports 50xx. It is firewall defaults settings. :slight_smile: I am glad that we figured out the problem :slight_smile: