Dashboard unresponsive lag - raspberry pi [Solved: Kernel Issue]


#1

Hello,
I am running raspberry pi 3 with desktop dashboard.

I accidentally upgrade the kernel to 4.9 and then downgrade it ot 4.4.50
I am not sure if it is due to update, but the dashboard becomes completely laggy and unresponsible. Also relay board are getting very long to connect:

If I close the tab with the dashboard, the browser goes fast and there is no problem.
Also I have noticed a problem with MQTT devices. They can not connect. If I restart, sometimes they connect and sometimes not. Also they are listed as OFFLINE, but last packet data send is just a seconds ago and widgets values are changing.
I have also note that when try to open the Raspberry pi device in Android app, nothing is showed. Arduino is working fine.
Also trigger a relay is taking too long (the widget is rotating).
Note also how many DS18B20 are added automatically to the dashboard:


What is the stable Kernel that we have to use?, because I am pretty sure that is from the update and downgrade that I have made.
Thank you :slight_smile:


#2

I have deleted the raspberry pi and the Dashboard immediately start to work as before (no lag).
After that I try to add the raspberry pi as new device, this is after the process was finished:

It is added and connected, but the widgets are not working.
Note that I have downgraded the firmware to 4.4.30 before removing and adding the raspberry pi again.

Also note how many sensors automatically are added:


#3

I’m not sure if this is related to Kernel version, we’ve seen this long ago in the past with DS18B20 replication but were never able to reproduce it / squash the bug.

I don’t know if this minor kernel version matters but, all of my Pis (default Jessie installs) are on 4.4.50+.

If you want to change to that kernel, try this command:

sudo rpi-update 52241088c1da59a359110d39c1875cda56496764

You’ll need to manually reboot after it finishes running. You’ll also likely need to clean things up again to see if it had any positive effect on your Cayenne performance.


#4

Hello,
I completely reinstall the Raspbian Jessie. Now the problem has gone, so dear USERS, NEVER upgrade the firmware, otherwise you have to recover your system!

Thank you!


#5

I will add what I added in our chat for anyone reading here, which is that we have an update for the Cayenne Agent that works properly with the 4.9 Linux kernel coming soon – it is currently in QA on our side. Please keep an eye on our Announcements category, I’ll be sure to update in Release Notes there when it is live.


Raspberry Pi shows as offline intermittently
#6

so, none of my relays are triggering.
is this the issue?
I didn’t update anything on the pi though.
dashboard says it’s triggered but i’m not hearing any clicks.
seems like soon as i tried to do anything manually it stopped working?


#7

I don’t think! Mine was absolutely lagging. Also browser was crashing and nothing works.


#8

are right.
I did some troubleshooting and found the power-supply for my relay board had a broken wire in the line.


#9

I am glad that you solve it!


#10

@ognqn.chikov

I just wanted to bump this thread to note that we’ve now updated our Pi agent to support the 4.9 kernel (it still supports 4.4 as well). The update was automatic in the background so there is nothing you need to do on your end. Feel free to use rpi-update to move forward to the 4.9 kernel at this point if you’d like!


#11

Cool. thank you. I will test :slight_smile: