DS18B20 Fahrnheit - Celsius


#21

Man that was a quick response! Thanks for letting me know Benny.
I thought I was going mad!! :slight_smile:


#22

Hey @MuniWobbler,

I want to make sure we’re addressing the case that you saw though. The fix I’m aware of coming soon is to allow the Raspberry Pi CPU Temperature widget (which we place on your dashboard on a fresh Pi install) to have Celsius. And this is specific to the Android app.

But you’ve mentioned sensors in your post, and a hang while saving. So I’m not sure its the same thing. What platform are you trying to make the change on? iOS/Android or web browser? What sort of sensors did you try? And if you try something like renaming the same widgets (but leaving the Temperature set to F, for now), does that save either?


#23

Hi rsiegelI’ll try to answer your questions one by one.I’ve tried this with three windows 10 machines using either Chrome or Edge as the browser.The Pi install was completed one week ago.The sensor I was using is a DS18B20.The ‘hang’ occurs when trying to change from Fahrenheit to Centigrade. In the drop down menu you can see the option, select it but it just sits there when you try to save. The button changes colour when pressed (and then back again) but nothing happens. I tried leaving it for a while (overnight) but it was still there doing the same thing in the morning.I can create a widget and everything works when set to Fahrenheit. But you can’t change it to Celsius!I have deleted and created the widget at least a dozen times in total (on two different Pi with the same build) and have tried doing the renaming thing. Still no Celsius.Cheers


#24

@rsiegel
I seem to have the same problem as @MuniWobbler, i have 4 ds18b20’s connected.
When i go to their settings and try to change the general settings (like degrees) it refuses to save.
I can push the save button but no action is performed.
I’m using a Pi B+ and google chrome on a win7 pc.

Greetings a Cayenne fan :smile:


#25

@ledsrepair, @MuniWobbler,

Thank you for the detailed information. I am now able to reproduce this on our web dashboard with my own pi’s and DS18B20 sensors. It looks to me like its not related specifically to the Fahrenheit vs Celsius units setting, but just that any setting change on that widget is not saveable. On my end, I can’t even rename the widget, the Save button just isn’t behaving for this sensor.

We’re investigating internally and I’ll update as soon as I know more.


#26

@rsiegel
Thank you.

Indeed, i have the same problems as you mention in the web browser version .
Something strange happend in the Android app. One of my ds18b20 sensors is in graph view there. And in that widget it was possible to change the degrees. When i go to the other widgets i get a notice that cayenne has stopped.


#27

All of My Pi on test and various browsers
Can not change Deg F > Deg C
and
Can not change to graph plot
Save button looks like actively clicks but just stays there and nothing updates or goes back to main screen
Tried various OS and am now trying from scratch wipe out fresh jessie install.
~ Andrew


#28

Also… Screen generally VERY boggy and slow (10 to 30 seconds to respond) but much better with fewer Pi on dashboard and or fewer pointer gadgets. Changing Mem, Storage and % back to digial only display speeds things up significantly…
History / Cache full to overflowing ?
Pretty much same on Chrome / F Fox
~ Andrew


#29

Have deleted all but one project and browser is now responding almost normally… Saving settings when changing things hangs until clicking off the settings foreground, then doing a dashboard reset sometimes changes things but can not change to Deg C at all.
~ Andrew


#30

At the risk of “me too”… me too. DS18B20 working fine in farnheit but will not move to C.


#31

Hmm seems to be working for me. What device are you using?


#32

Completely re flashed card and re install and still can not change to Deg C
Dashboard ''pretty laggy" on various OS and browsers
~ Andrew


#33

Same here - DS18B20 shows Temperature only in F but not in Celsius.

Is there a config file to change the value?


#34

I think that it may be a wider issue. As well as the settings problem I am struggling to add a new project and to remove a widget I previously added to the screen.

I’m running safari v 9.1 on Mac OS X El Capitan but I recreated all of the issues with chrome.


#35

There is like an invisible elephant bogging down the responsiveness / GUI to almost un-usable speed at present…
Happy to try any thing out / suggestions…

Can the account be somehow purged / reset / dumped ?
I don’t mind re-install as it is un usable at present

~ A


#36

I’ve got the same problem in the desktop dashboard, but it was working in the ios app if that helps anyone.

using a pi and DS18B20.
/P


#37

@picaxe @paul.hellfalk looking into this now.

-B


#38

@picaxe @paul.hellfalk looking into this now.

-B


#39

Pi - Update on this. Using cayenne through safari on a Mac I get a lot of odd issues such as this one but now I have installed the app on my iPhone I can change c-f and also do other things which just don’t work on the web portal.


#40

I have problem too with Fahrnheit-Celsius