Elsys ESM5k not displaying any values


#1

Hi
I have set up a gateway and sensor that sends frames to loriot.io.
In loriot.io i set output to "myDevices Cayenne"
In Cayenne I added an loriot SM5k sensor with the same DEVUI that is used in loriot.io.
The problem is that “nothing” is displayed in Cayenne for that sensor, but I got a message at the bottom of the page saying "last data packet sent: that is just a few seconds ago"
Please advise what I missed.


#2

It think that the device is successfully connected, but the data message is missing. Can you check the type and format of the data that you try to send.


#3

Thanks for the fast reply.
I’m pretty new to the LoRa-stuff.
I see the payload in Loriot.io, but it’s encoded.
My sensor is set to send payload as Payload type = elsys, the other option I got is "Raw"
BR
Sven Hasselblad


hmm strange, my screenshot is removed but I see it in preview…
anyway my data iin loriot.io looks like 01 00 eb 02 1c 03 02 01 c0 0f 00 04 00 26 07 0d 20


#5

Can you take a look here. I also do not have big experience with LoRa and it will take me more time to investigate


#6

Yes I have checked out the documentation for lora, although not reading (or understanding) it from a to z.
My impression was that since Cayenne have support for Loriot.io and the Elsys sensor I’m using, then Cayenne should be able to interpret to payload out of the box.
Thanks for your time.
//Sven


#7

Looping in @croczey .


#8

Hi @svenhasselblad

I took a look at the payload that is arriving at the network server. The payload checks out, here is what is being decoded in our back end:

[
    {
        "channel": 1,
        "type": "temp",
        "unit": "c",
        "value": 23.5,
        "name": "Temperature"
    },
    {
        "channel": 2,
        "type": "rel_hum",
        "unit": "p",
        "value": 28,
        "name": "Humidity"
    },
    {
        "channel": 3,
        "type": "accel",
        "unit": "g",
        "value": [
            2,
            1,
            -64
        ],
        "name": "Acceleration"
    },
    {
        "channel": 15,
        "type": "motion",
        "unit": "d",
        "value": 0,
        "name": "Motion"
    },
    {
        "channel": 4,
        "type": "lum",
        "unit": "lux",
        "value": 38,
        "name": "Luminosity"
    },
    {
        "channel": 7,
        "type": "voltage",
        "unit": "v",
        "value": 3.36,
        "name": "VDD"
    }
]

I suspect that the reason it is not showing on the Cayenne dashboard is due to a data storage hiccup that we experienced this morning (PST). Can you please remove the device from Cayenne and try re-adding it?

If that still does not work, please reply with the DevEUI for the device and I will see where the data is getting stuck.

Thank you!

-Camrin


#9

Hi
I have removed and readded the sensor, unfortunally no data showing.
The DevEUI is A81758FFFE0303FB


#10

Can i have you please try replacing the data output with HTTP POST. From there, you will need to manually enter the path: https://lora.mydevices.com/v1/networks/loriot/uplink


#11

That did the trick, now it’s working.
Thanks!


#12

Hi! Sorry for being off topic in an old thread!
I was searching for documentation regarding the Elsys ELG connecting to Loriot.IO but having some difficulties finding it. May I ask you how you’ve configured the Elsys ELG and what type of Gateway you registered in Loriot.IO?
Thanks!


#13

Hi
No problems.
Regarding loriot.io, there I use git Semtech packet Forwarder
Channelplan: EU868_Semtech

Regarding the gateway, I first tried the loriot.io config with no luck.
Then I tried the other config and it started to work.
I don’t have access to the gateway right now :frowning: so I don’t have more details.
Hope this helps you forward!
//Sven


#14

Thanks! Just received some information from the manufacturer of the ELG and I thought I let you know:
You can on Loriot.io set up an “OpenWrt/Lora mCard/USB”. On the GW, then just select Loriot. It seems to work (connection is active) but I have to reconfigure our ERS1 and it’s currently in another city!