Format of LPP for Loriot

Hello there,

I joined a couple of days the community and now I have a little problem. I collect some sensor data (DHT temp sensor) with an Arduino board. I send this data with a Dragino LoRa Shield to our Lorix LoRa Gateway and put it into the Loriot Cloud. So far so good. On the interface I can see the incoming data, it looks that everything works.

Now I want to visualize my collected data and I joined I implemented my device and chose the LowPowerPayload. I worked through the documentary and understood how the Payload should be.

I worked on my code and now it is in this LPP Style ( I can see it in the Loriot Cloud Interface).

But nothing happend in the Dashboard… I can see that it received some data but not how it looks like (the structure). At the moment my Payload has this structure:
[Data Channel] [Data Type] [Data]

for example: 01 67 09 24

Is there something in front needed? Maybe an ack byte or something like that?

Thanks in advance.
Cheers, Jan

@croczey :slight_smile:

Thanks for the fast reply.

Now I have to make an update:

I just changed the Output on the Loriot Cloud (to Cayenne) and restarted the Gateway and now it works. :laughing:

234 C. What are you making, a flamethrower? :stuck_out_tongue:



Yes, I noticed it too. I made a change to my code but there is no update to the dashboard. I will have a look tomorrow.


EDIT: Ok now It works!

Hi Jan,

The whole LoRaWan thing is tricky.

I found on Loriot if my fields were not even, it will prepend a 0. Cayenne doesn’t like this.

My experiences: HowTo - Haxiot Gateway and Shield



Yes, I start to understand :smiley:

Thx for the tutorial. Today I want to implement the Humidity.



EDIT: So I implemented the humidity value into the payload. But nothing happend… I just restarted the gateway, maybe it will help. I checked the structure of the paylod (Loriot Dashboard). It is ok.

EDIT 2: So another Update to this. After the implementation of the humidity value my dashboard didn´t show anything. I tried a lot (some restarts of the gateway ect.). Now I made a step backwards and deleted the part for the humidity.
Now it works and show me the temperature. I saved the sketches (only for temperature and for both). If I upload the sketch for both values (temperature and humidity) I got the error.

If I upload the sketch only for the temperature, it works directly. So it seems that I got the problem, when I want to show both values.

Hi @jan.hamers,

Could you try humidity by itself with a dummy value for humidity?

An example would be:


03-> Channel 3
68-> Humidity
64-> 100 decimal * 0.5% = 50%



Hi Craig,

Thanks for your reply. It´s a good idea. I m not sure if I did this. What I tried was to shortened the payload (only to transmit the value for humidity). But I didn´t work.

Finally I found a solution. I changed the Data Type for humidity in the payload. Now I use an analog input for humidity. And now, it works! :slight_smile:

Now, it´s a good thing to visualize some sensor data. But sometimes, the dashboard shows some “crazy” values/data. I think it´s the transmission from the gateway to the mydevice / cayenne server.

I doubled checked the incoming values at the gateway (data which is sent by the LoRa Shield). This is ok!

If you want, I can try your suggestion!


I tried your suggestion. It works!

1 Like

When you were using humidity, what was the data output?

010208fc should give you a data value of 2300, and display as 23.
0202114e should give you a data value of 4606, or 46.06.

So yes, you can use these, and the humidity one, but you must send one byte only for humidity in the frame.

My concern is that the Loriot Gateway is pre-padding if the payload is not even, so even if you did give the right data, it becomes invalid as 036864 becomes 00036864.

I am trying to confirm if this is just me seeing it, or everyone.

So if you send just 036864, what do you see for received data in the Loriot app dashboard?



I tried it and please find attached the picture of the Loriot Dashboard. It seems that the LPP Payload will work with a constant value.

I think, I will double check my Arduino sketch. Maybe there is something in it that “confuses” the LPP Payload.

Thank you very much for your help.

BTW: After the upload it worked directly on the Cayenne Dash!

1 Like

So no pre-padding for you. Weird.

Granted, I don’t get it all the time, but occassionally me ant @croczey saw an output with a pre-pended ‘00’ when my debug message clearly didn’t have it.