Greyed out "Channel" when adding a digital input

Thank you for taking the time to submit your bug/issue! Please use the points below as a guide when submitting.

  • Device & model you are using: Pi 2

  • What dashboard are you using? Web

  • Please describe the bug / issue as detailed as possible. Attaching the code and any relevant screenshots would be very helpful!

I try and add a device, Add new - Device/widget - select Sensors - Generic - Digital input. I can select device, connectivity (change to intergrated GPIO) but channel is greyed out. What am I doing wrong?

Welcome to Cayenne!

That’s definitely odd, seems to be ok for me. Do you have any popup blockers like ublock? Sometimes they can do some funky things.

Can you share a screenshot?


Thank you and thank you for the reply.

I tried a different browser with no pop-ups but still the same results. See screen shot. When I run my mouse over “Channel” it changes to a red circle with a line in it. Add sensor is also greyed out.

See my reply to Adam.