Install was a snap. Easy UI request and a question

Learned about mydevices from the PI Podcast. Install from the iPhone was a drop dead simple. Thanks!

  • Request: Add a confirm option to the ‘shutdown’ and ‘restart’. I have hit these by accident already. ;(

  • The app only found my two newest PIs on my network. Are the older PIs not supported?


We’ll have confirmation pop ups for those actions on next iOS release (this week?). Hmmm…what Pi models didn’t get discovered? We’re making improvements to the discovery feature on next iOS app release as well.


Fantastic! I look forward to the confirmations on the REBOOT and SHUTDOWN.

All my RasPIs are on the same WiFi SSID.
The iPhone app found the Pi2 Model B and Pi2 Model B with no problem.
However, it did not ‘see’ my three Model B (older) RasPIs.


Strange. It finds my model As even.

@Voltar . I’ll be interested to see if the iOS discovery improvements we’re releasing have an effect on the older Pi’s.


No problem. I’ll wait for the new iOS release and report back. If you have something you want me to test let me know and I will see if I can help.

Another data point: Since kreggly (above) said it worked with the older devices I went back and double/triple checked that my older RasPIs were indeed on the same WiFi network as the iPhone. They are. I was able to VNC into the older RasPIs with my iPhone, but they are not discovered by the Cayenne app.

Thanks for checking again. Ultimately, there will always be edge case scenarios where Cayenne discovery feature does not work… As work around solution, we have implemented ability for you to manually enter IP Address into app to SSH into the Pi and do push the installation. It would be great if you could test this feature on your Pi’s that weren’t previously being auto discovered!



Thanks and totally understand the ‘edge’ case come back.

When I run the app from the iPhone I do not see anyplace to manually enter an IP or a SSH screen. I am presented with a screen that shows my connected devices and a refresh icon. How do I get to the manual IP/SSH entry screen?

In other news, If I do a press the refresh button the two RasPIs that I already have connected show up twice on the screen. Once as connected and once with the setup icon. My suggestion would be if a RasPI is already setup with Cayenne it would not be presented as a option for another setup. Dunno, maybe there are reasons to setup multiple times on the same device that I am not aware of.

Thanks again.

Oh right, sorry for not being more clear. The manual IP address ability will be in next release…not currently available.

This will also be fixed. We saw issues where users were doing multiple installs on top of each other, which led to major connections issues. Thanks for sharing these! Please continue sharing too, it really helps :slight_smile:



No problem. Looking forward to the release. I run “Test Flight” to help with iPhone app betas. Let me know if I can be of help.

As I get more into the app there is another easy UI request: Have some way to display the RasPI time of day. Why? It is a quick and dirty way to confirm the connection and show that data is updating.

Thanks again.

A data last updated message in the header (compared to your PC clock), and a client side alarm if data is lost for over a configurable time frame.



Got the new app. It did find one of my RasPI’s that was not located by the older Cayenne iOS rev. FWIW, this RasPI was hardwired to the router. The WiFi RasPI’s were still not found.

But… No problem. I did install your client manually with the commands listed on the website and, BOOM, all is well.

Small bug…

I has DS18B20 temp sensors on the RasPI. When I try to change the senor to a more human readable name like “Attic TempF” the change does NOT get saved unless I change and save the display method as well (example: from graph to value, etc.)