Installing Cayenne on Raspian Stretch Lite

  • Device: Raspberry Pi 3
  • OS: Raspbian Stretch Lite (version September 2017, release date: 2017-09-07)

I’m trying to install Cayenne but I get the following error:

Mon Sep 18 10:35:44 UTC 2017 Installing myDevices agent
Mon Sep 18 10:36:27 UTC 2017 Found Python 3.5.3... 
Mon Sep 18 10:36:27 UTC 2017 Copying agent libraries
Mon Sep 18 10:36:28 UTC 2017 Installing python utils
Mon Sep 18 10:36:37 UTC 2017 Installing software components
Mon Sep 18 10:36:38 UTC 2017 Cannot install for Python 3.5.3 : missing development headers\n
Mon Sep 18 10:36:38 UTC 2017 Finished agent code
Mon Sep 18 10:36:38 UTC 2017 ERROR: myDevices cannot be installed - please check errors above

Now, I’ve seen that other people have had this same issue on other Lite versions of Raspbian. Is Stretch Lite not supported?

HI @paetur.magnussen,

We currently provide support up to Jessie lite using linux kernel 4.4. We’re working to support the most recent version of Raspbian released. You can downgrade your Raspbian version to Jessie w/ 4.4 linux kernel and should work fine.


1 Like

Hello Benny

Thanks for the info. I just went to the Raspbian site to download the Jessie lite version and could not find it. This made me think. Before I start pulling cards and doing fresh installs from an old copy of jessie lite, I just need to ask. Is there a way to downgrade without doing a fresh install? Say over ssh mabe?

I have two rpi3’s and two rpi0w’s


Edit. If anyone else is looking for jessie lite here is a link. Index of /raspbian_lite/images

1 Like

Thanks for posting that link @ccdanieldb.

We actually just pushed out an update for supporting the new 4.9 linux kernel.

If you create a new Raspberry Pi device in your account, the install commands that are generated will contain this update. If you have some time and want to test if our updated agent works w/ new linux kernel, please do so and let us know how it works out! We will eventually be rolling out the update to existing Pi agents, but for now we have contained it to only newly generated Pi 's inside of Cayenne.


1 Like


Hi guys,

I too am having this exact same issue with the latest version of stretch lite…same python error as above…

Am i missing something here?


Try these commands:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install python3.4
sudo apt-get -f install

Cheers Adam,

I ended up forcing a reinstall of python3.5 and added the python-dev also, from here it worked fine.


1 Like

Was having the same error message when trying to install Cayenne from the cli on a clean install of Stretch Lite and found the fix was to do…

sudo apt update
sudo apt upgrade
sudo apt install python3-dev

before following the instructions to install Cayenne from the cli.

1 Like