Data interfaces inconsistent and hard to manage


#1

Running on Pi 3b, accessing DS18B20

First the goodness … wired up the sensor on breadboard, connected to powered down Pi, powered up and bingo - sensor detected and installed and visible on iPhone, iPad and web dashboard … excellent… BUT…

  • Presentation on iPad dashboard excellent! This was the first route by which I accessed the data (which I assume only exists in your servers and is accessed by the dashboard for presentation). It updates continuously and when I select the different intervals they all display. (NOTE - the “last day” display orders the data from most recent on left to oldest on right, which seems odd to me! All other charts are the other way around! )

  • Presentation on iPhone - “live” works fine, but all other choices of interval show “No data available for this period” - seems odd since I know it is there and can see it on my iPad!

  • Web dashboard - since I cant get it to show anything with Firefox I tried Msoft Edge. I have discovered that for “live” if you just wait it does appear in the end and settle to a reasonable graph scale. However, nothing displays for any of the other intervals, even though the data is there.!

Temp0|690x338


#2

Further screenshots from iOS


#3

it seems like there was an issue while adding the DS18B20 as on the web dashboard it just shows an icon widget with no value. Can you try deleting the widget first, then re-adding it from the web browser.


#4

Hello Shramik!

I deleted the widget from my iPhone and the web dashboard but not iPad. In both cases of delete Cayenne immediately found the device again and I could “add” it.

I did this first on the iPhone - everything worked, after a few moments the “cog” appeared on the widget and I could see graphs in all categories.

Then did it on the web dashboard. Again, all worked, but I note that any historic data prior to that point seems to have gone?

At that point iPad and iPhone lost all but “live” data! Grrrrr!

So… closed down apps in both devices and opened up again. Voila! Data and graphs re-appear, but only from point at which delete/re-add occurred. I notice however that in the apps (not the web) the device name now says “channel dev:nnnnnnn” rather than DS18B20. I can edit that, but obviously the add process somehow used this not device type.

Web interface now working just fine. I find the “zoom” hyper sensitive and hard to control, but that might be my mouse settings :wink::worried:

PS - as a separate request could you please point me to any instructions for complete de-install of cayenne? I have it on a device where I don’t need it and would like to do a clean uninstall. Thanks.


#5

you can only see the data in the chart from the instance the widget was added to your dashboard. the data before removing the widget are lost.

this issue is at our end and we are working on it.

https://mydevices.com/cayenne/docs/getting-started/#getting-started-raspberry-pi


#6

Maybe I’m being very dim, but I can find anything in that link about UNinstall?

I like to be sure that all traces of unwanted software are gone!

Should I (a) just remove the device from the dashboard or (b) run the uninstall script that is in one of the directories or © both?

Thanks, David


#7

you can remove from the dashboard or use this to remove from pi /etc/myDevices/uninstall/uninstall.sh


#8

Removing from both app and web dashboard has not removed anything from the pi!

The script fails in line 8, I deduce because it expects an argument of some kind. Looking at the script it seems to expect “-full” as at least one possibility. Are there others?

Thanks

David

PS - this is the result of trying the script…

pi@DDhomepi1:~ $ sh /etc/myDevices/uninstall/uninstall.sh
/etc/myDevices/uninstall/uninstall.sh: 8: /etc/myDevices/uninstall/uninstall.sh: Syntax error: “(” unexpected


#9

try sudo /etc/myDevices/uninstall/uninstall.sh


#10

OOPS!

Thank you!