No data coming in from The Things Network

Hi, this is probably a noob question, but it seems I am stuck. I have a working Dragino LSN50 with a temp sensor registered to TTN. In the TTN console I have activated the MyDevices integration and on mydevices.com I have registered my node:

Device > Lora > the things network > Dragino Technology LoRa Sensor Node-LSN50 > entered my DevEUI

Then I copied the key from the URL into the Mydevices integration on TTN

I have been waiting for a few hours now, but nothing happens. What have I overlooked? I can see the data flowing on the TTN console with measurements etc.

Any help appreciated!

are you using correct cayenne LPP payload format to send data to cayenne?

Thank you, Shramik. Probably not. I read about this payload and libraries for the Arduino but I am not aware that I need to do something for the Draguino LSN50. How do I do that?

are you referring to this node:

have you programmed it?

Yes, this is the node. It worked with TTN out of the box; no need to program anything. I just had to add a payload converter supplied by the factory in TTN

can you PM me the DevEUI, so i can check if cayenne receiving any data.

also what do you mean by this step?

I mean that I copied the last part of - Cayenne

“1c1aa7b0-5077-11e9-86b5-4fe3d2557533”

into to Process ID box on the mydevices integration on TTN

the process ID is just a unique identifier. you can use any name for it. anyways can you remove and re-add the device again.

I did this, no avail… How can I chack if there is a (any) connection between my node and Cayenne?

PM me device DevEUI. i will check the logs

I had same problem. After upgrading LSN50 firmware to 1.6.3 and using Dragino LSN50 1.6+ now is working.

Thanks for reporting it @iot.hhcv

I had similar problems with a RAK7204 environment sensor. For me, what finally fixed it (after I had overcome the very poorly documented “Process ID” hurdle, and set an appropriate payload format) was resetting the frame counter on the device in TTN.

1 Like