Problems with Historical Data


Hello Community,

I have a project where I take readings of three water tanks. The readings are Level(through HC-RS04s Ultrasonic sensors), EC and Temperature.

I’ve been having troubles with the HC-RS04s readings. I can see the Live, Last 10 minutes and Hourly feed normally but when I try to go to Last 24 hours or the other higher timing views, it simply says ‘No data available’, even though all the other readings(EC and Temperature) will display data in said same options. Is that a particularity of the Ultrasonic sensors or could it be something else?

Thank you!


Hi @rmbatistic,

It could have been that you tried viewing before we had enough data to display for you. Have you tried again recently?



Any luck with that sensor data @rmbatistic?


Hello @adam and @bestes, sorry about the delay, I was really busy this last few days…

Yes, I had been running the system for two weeks already at the time that I first posted in this topic(it began on 10th of November) and all the other sensors were displaying data for daily, weekly and monthly feed then, except for the HC-RS04s… By now, the problem remains, since I haven’t changed the code at all…



Are you using MQTT?



No, I’m using an Arduino Mega with a W5100 Ethernet Shield


It’s interesting that the live and 10 minute increments work but nothing more. @rsiegel might be able to get some more info about what’s wrong here.


@rmbatistic, I’d be interested if you could open up your browser console before trying one of the graph tabs again. This depends on your browser, for example, in Google Chrome is under View > Developer > Javascript Console. Let me know your browser if you’re not sure how to find it.

I suspect what’s happening here is that when you query for larger amounts of data, the request is timing out before it is completed from our database (the bigger the tab, the larger the request, the longer the search). Seeing your console output would help to confirm so I can tackle this with our engineering team.


Hello @rsiegel! (Just edited since I forgot to add the @…)

Well, I’ve just opened the Console by clicking Alt+Shift+J on Chrome. All I get there are plenty of these:

"602e6060-c09d-11e7-96e0-ed3a4c51948a:1 Slow network is detected. Fallback font will be used while loading:"

If I then take out all the filtered messages, I do get some violations aswell:

[Violation] ‘setTimeout’ handler took 185ms
[Violation] Forced reflow while executing JavaScript took 161ms
12format+pt_BR,default+pt_BR,ui+pt_BR,corechart+pt_BR.I.js:308 [Violation] Added non-passive event listener to a scroll-blocking ‘mousewheel’ event. Consider marking event handler as ‘passive’ to make the page more responsive. See
gvjs_lm @ format+pt_BR,default+pt_BR,ui+pt_BR,corechart+pt_BR.I.js:308
gvjs_V @ format+pt_BR,default+pt_BR,ui+pt_BR,corechart+pt_BR.I.js:307
gvjs_VC @ format+pt_BR,default+pt_BR,ui+pt_BR,corechart+pt_BR.I.js:859
gvjs_ufa @ format+pt_BR,default+pt_BR,ui+pt_BR,corechart+pt_BR.I.js:1342
gvjs_tL @ format+pt_BR,default+pt_BR,ui+pt_BR,corechart+pt_BR.I.js:1536
gvjs_.Jca @ format+pt_BR,default+pt_BR,ui+pt_BR,corechart+pt_BR.I.js:1540
gvjs_vm @ format+pt_BR,default+pt_BR,ui+pt_BR,corechart+pt_BR.I.js:317
gvjs_.dispatchEvent @ format+pt_BR,default+pt_BR,ui+pt_BR,corechart+pt_BR.I.js:315
gvjs_.j7 @ format+pt_BR,default+pt_BR,ui+pt_BR,corechart+pt_BR.I.js:329
[Violation] Forced reflow while executing JavaScript took 32ms
vendor-4cd0390d50.js:279 [Violation] ‘setInterval’ handler took 52ms

After I’ve changed the Datalog of the HCs from Hourly to daily, I also got other Violations similar to these two:

“vendor-4cd0390d50.js:160 [Violation] Added non-passive event listener to a scroll-blocking ‘touchstart’ event. Consider marking event handler as ‘passive’ to make the page more responsive. See
vendor-4cd0390d50.js:160 [Violation] Added non-passive event listener to a scroll-blocking ‘touchmove’ event. Consider marking event handler as ‘passive’ to make the page more responsive. See

They repeat a lot of times, somewhere around 30x.

It’s clear to me that my network is very slow, but since I’m using an Ethernet cable to the Shield, I thought there would be no problems with that, especially because all the other sensors are working fine…
I’m terribly sorry to say that I have no clue if those would help at all, if you need more information I may try other things… Thank you once again and sorry if I didn’t display the correct information you needed.


I’m sorry to bother you @rsiegel but have you had any luck with my Console messages? Do you need more informations? Thank you!


I don’t see what I was expecting in those console messages, no. I was expecting a 504 Gateway Timeout error message more like the one in this screenshot, which would indicate there was an issue with our server timing out before it could pull all of the requested historical data.