Raspberry Pi Zero installation



I am a newbie to the community and I need some help. So far I have installed Cayenne on RPi 2 and RPi3 with some relays and it works perfect, I am so glad I found you Cayenne :grin:

My plan is to install Cayenne on RPi Zero which will host a PIR sensor and couple of other sensors, however, I am just getting stuck installing Cayenne on to RPi Zero, out of couple of attempts it installed once, that too after a restart it wouldn’t recognise the sensor anymore, and the other times, even after an hour or more of waiting the installation wouldn’t complete.

I tried with Raspbian Jessie lite and Raspbian Jessie , and made sure RPi is connected to the internet.

Please help!


Cannot install cayenne to rasp pi zero wireless
Installation stops on Software Components

@ian has a project running on a zero. Are you having any similar problems?


Hi @soubir,

Have you been able to install Cayenne on a regular Raspberry Pi 2 or 3 with a Jessie image?




Hi @kreggly ,

Yes , i have been able to install the same image on RPi3 and RPi2 and its working great.



Ok, then I think you should try generating a new install script instead of re-using the old one, then take a look at this:




Hi @kreggly,

I tried the instructions mentioned on a fresh Jessie install after apt-get update and apt-get upgrade, did hit the enter multiple times as mentioned still nothing. I tried to install using SSH and using mobile but still the installation wouldn’t complete. Below is what I saw on ssh.



@rob, have you seen this output before?


I’ve seen that error plenty, though I don’t recall if it was ever in the context of a Pi Zero. Likely doesn’t matter.

Generally this is resolved for most users by running these 5 commands (and answering yes to any prompts you get):

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install python3.4
sudo apt-get -f install


I knew you’d have the answer! Rock stars everywhere :stuck_out_tongue:




Hi @kreggly & @rsiegel,

Thanks for the instructions, I have followed the instructions as mentioned and started all the installation on a fresh jessie installation. However, in the end Cayenne still didn’t get installed :disappointed:

Here is a screenshot from my ssh.

Also, just to add, when I search for the RPi using my mobile, it wouldn’t show up, I have to manually identify the RPi using the IP address, not sure if this means anything. In the meantime I installed Cayenne on a RPi2, completed it without a hitch.



Sometimes the mobile app device search can be a little inconsistent about what it finds, I don’t think that’s related to the install trouble you’re having here.

Do you mind running the install once more (even though we know it will fail), and copying the full output to a text file so I can see if anything funny is going on before it terminates with the python error?


Hi @rsiegel,

Apologies for the delay in getting back. I tried the whole process as mentioned, however as mentioned with the same outcome.

Here is the output.

pi Jessie Cayenne installation.txt (144.4 KB)




This is a Microsoft Word file, Rob. Just change the extension to .doc…




Thanks for the detailed log soubir. I didn’t see anything that jumped out at me in the process that looked wrong. I don’t want to tell you to re-flash your SD card as you’ve already mentioned that it’s a clean image.

I’m going to contact the developers of the Raspberry Pi agent to get their opinion as I’m a bit stumped. I’ll report back here as soon as I hear from them, thank you for your patience.


Hi @rsiegel,

I got some time and tried in on fresh install connected to wifi/ LAN (through OTG) I got the same result. Also, I wanted to make sure nothing is wrong with the RPi Zero, I tried it on a RPi A+, however had the same result. Please help as I got a bunch of Zero s and A+ with a plan of home automation.



Do you have some installations made before installing cayenne? Maybe some permission problems?


Hi again,

After speaking with the developer of the Pi agent installer, I have a few steps for you to try to get more detailed log output for him:

  1. cd into the myDevices-1.0/python dir
  2. Run sudo python3 setup.py install --verbose --force --record "/etc/myDevices/uninstall/installed_agent"
  3. When it finishes or errors out run echo $? to print the error code

At that point we’d be interested in both the output from steps 2 and 3.


Hi @tooony,

I have successfully installed Cayenne in 1 RPi 3 and 2 RPi 2 without any issues.



Hi @rsiegel,

Here is the output. This installation was done right from scratch.



You’ll have to use the command “echo $?” to get the output from the previous command.